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Part I - BRASS Basics
BRASS Contacts
For hardware or connectivity help
BTS Help DESK

Remedy Mail Service

823-5199

For help using BRASS
Bureau Program/Project Managers: Contact your bureau’s Budget Analysts.
Bureau Budget Analysts: Contact your bureau’s CBO Analyst.

Before You Start
BRASS will let you enter data for existing fund centers, funds, functional areas, funded
programs, grants, and commitment items (referred to as master data). You cannot establish new
master data elements directly in BRASS; all master data elements are created in SAP and
interfaced to BRASS.
BRASS and SBFS will allow you to enter information on new positions through decision
packages or modify existing positions. Data elements allowed are class, grade/scale, step/salary,
category, etc. You cannot create these data elements in BRASS, you have to work with BHR to
get these created in the HCM module in SAP as these elements are interfaced to BRASS
If you need to request additional performance measures, or change existing measures, contact
your CBO analyst.
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BRASS Features and Terms
Below are some of the key features and terms in BRASS you will want to know.
FEATURE
Salary and Benefits
Forecasting System
(SBFS)

Budget Forms

DESCRIPTION
Database of position and employee
information, uploaded from the SAPHCM module. SBFS projects salary
and benefits costs that are used in
budget development.
Data entry screen for entering budget
amounts not calculated by SBFS.

Performance Measure
Values

Data entry screen for entering
performance measure values.

Audit Trail

List of all changes made to an
individual budget form.
Data entry screen for decision
packages, projects, and performance
measure narrative and parameters.

Info Edit

Reports

Spreadsheet Views
(and Advanced
Spreadsheet Views)
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Pre-formatted displays of budget
information. They can be viewed on
screen or printed.
Reporting tool that can be formatted
(designed) by the user. They can be
viewed on screen, printed, or exported
to Excel.

USES
Allocate staff across master
data elements. Update default
FTE amounts for part-time
positions. Extend limited term
positions.
Separate forms for technical
adjustments, decision packages,
and capital projects.
Enter prior year, current year
estimates, and budget year
performance data.
Identify details relating to
changes in budget forms.
Enter text and other attributes
related to decision packages,
projects, and performance
measures.
View information entered via
budget forms.
View information input through
budget forms, SBFS and other
sources. Export information to
Excel for data manipulation.
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Part II – Getting Started in BRASS
Logging into BRASS
1) Start from your desktop.

2) Double click on the BRASS icon.
3) You will see the BRASS Application Screen.
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Select relevant database from the Database selection box and click on <OK>.
Note: Select ‘Training’ for practice.
To build your actual budget, select ‘Production.’

4) You will see the Please Login box. Type in your username in the Login field.
If you have already established a BRASS password, type it in the Password field. Until you
establish a password, leave the Password field blank. Click on <OK>.

5) You will see the BRASS home screen. You have successfully logged in to BRASS.
Note: Each database in the selection has a separate password. Creating a password in one does
not create one in all of them. It is highly recommended that users use the same password in all
the databases.
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Establishing a Password in BRASS
From the menu on the home screen, select Utilities > Change Password. The Change Password
box will display.

Enter a password in the New Password field, and reenter it in the Verify New Password field.
Click on <OK>.

Navigating in BRASS
BRASS uses standard Windows application navigation tools:









Menubars
Dropdown Menus
Toolbars
Icons
Buttons
Radio Buttons
Status Bars
Scroll bars

BRASS home screen section:
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Navigating in Budget Forms
All BRASS forms have two components:


The parameter selection box is the place to select the master elements to be used and
general parameters such as serial number, description, and stage.



The budget form entry box is the place to enter budget data by master data element
and column.



Use the <Insert> button to add lines.



Data is entered through fields in the budget forms. Many fields include dropdown
menus that allow for selection. Click on the right side of a field to display the
dropdown menu.



For forms that have multiple instances of the same pieces of master data, cut and
paste to avoid using the drop-downs. Ctrl+C and Ctrl+V work for cutting and pasting



Dropdown menu survival kit: Some dropdown menus are very long. To advance the
menu to the entry you want to select, start typing in the field. For example, the
CommItem (Commitment Item) dropdown menu includes all expenditure and
revenue accounts. To advance to the expenditure accounts (which follow the revenue
accounts in the dropdown menu), click on the right side of the CommItem field to
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display the dropdown menu, and type ‘5’ to advance to the expenditure accounts or
‘51’ to advance to personal services.


Hover over a field to see a description of its contents, such as the fund center or
funded program name, displayed in the lower left of the screen in the status bar.



Click on a column heading to sort by the contents of that column, as well as display a
summary line for the column. Click on Seq column heading to reorder by line
number.



Error messages will appear if a required field is not populated when you try to save
the form or if a form that needs to be balanced is not.



Budget forms are for data entry. Reports and spreadsheet views are tools to show you
the results of your work and the work of others who may also be working in the same
master data elements.

If data is posted to a budget form and the spreadsheet view is open, click on <Apply> on the
form, then click on either the Refresh icon ( ) or File > Refresh, and the entered data can be
viewed in the spreadsheet view.
Navigating with Command Buttons
Buttons on the Parameter Selection Box
Reports the Form Justification, Objects (detail lines), and Audit Trail of an
existing form without opening the form.
OK – Opens a new or existing form. If any required fields have not been
completed, an error messages box will appear.
Cancel – Closes the parameter selection box.

Buttons on the Budget Form Entry Box
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Inserts additional lines into a form. When you enter the form, the hand pointer is
on Line 1. If you need to insert additional lines, you can do so by clicking on
<Insert>.

Deletes a line from a form but NOT from the database. (To remove information
from the database, enter zeroes in all of the posting columns, and click on
<Apply> or <Save>. Once the line’s posting columns are all zeroes and the
information has been saved, you may delete the line from the form if you wish.
BECAUSE TECHNICAL ADJUSTMENT AND INFRASTRUCTURE
FORMS HIDE COLUMNS FROM PREVIOUS BUDGET STAGES,
NEVER DELETE LINES IN THESE FORMS.)
If you find you need to delete a line, use your mouse to select the line you want to
delete, and then click on <Delete>. Make sure the hand pointer is on the line
you wish to delete—there is no <Undo> button in BRASS. All you can do to
recover is to click on <Cancel> and lose any changes since the last time you
pressed <Apply> or <Save>.

Moves a line in the form. Place the hand pointer on the line that you want to move
and select <Move>. Position the pointer on top of the target location and click the
mouse once.
Audits the line entries to a form. When you click on <Audit> an Audit Trail
Report for your form opens in a new window.
The Net Cost dropdown affects how the bottom total line appears on a form.
There are three choices:




Net Cost
Sum Rev.
Sum Exp.

Total Revenues less Expenditures
Total Revenues
Total Expenditures

Note: This feature allows you to see totals for either revenues or expenditures
or for net revenues (expenditures). The selection in this field does not affect the
entries themselves.
Apply – Saves your work but keeps the form open to continue entering data.
<Apply> is the default button, so pressing <Enter> is the same as clicking on the
<Apply> button. It is useful to apply on a regular basis when working in forms to
ensure that work is not lost due to an occasional ‘Primary Key Constraint’ error

Save – Saves your work and closes the form.
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Note: Forms that are required to balance between revenue and expenditures will
not save if they are not in balance. Instead, an error box will display. The time to
save or apply depends on the size of the form.
Cancel – Closes the form without saving. Any entries made since the last <Save>
or <Apply> will be lost. If you click on <Cancel>, you will get a dialog box
asking you if you intend to discard changes.

Button You Will NOT Find in BRASS
Undo – Be careful!
Other Navigation Features


Press Ctrl+[mouse scroll wheel] to zoom in and out.



Use the Maximize and Minimize buttons in the upper right of your screen to
maximize or minimize a window.



Use the mouse to increase or decrease the size of a window by dragging its border in
or out (two-ended arrow).



Drag a window around the screen (four-ended arrow).



Use the scroll bar at the bottom of the form to move to fields that are off your screen
to the right.



Use the scroll bar at the right of the form to move to fields that are off your screen to
the top or bottom.



Hover over an icon to see a description of its function.



Make columns wider or narrower:
- Place your cursor in the gray header area between two fields above the first data
entry line. When you have the cursor in the correct place, it will change shape.
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Press and hold the left mouse button and a vertical boundary line will appear
between the fields.
Drag the line to the right or left until the field is the desired width. Release the left
mouse button.
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Part III – Budgeting in BRASS
This section shows how to build an operating budget step by step. This includes:
Building Your Budget in BRASS: An Overview
Budgeting Personnel Expenses (SBFS Position Maintenance)
Budgeting Interagency Agreements
Completing the Base Budget (Technical Adjustment Form)
Developing Capital Budget (Infrastructure Budget Form)
Using Info Edit for Decision Package, Funded Program, and Performance
Measure Information
Creating Decision Packages
Entering Performance Measure Data
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Building Your Budget in BRASS: An Overview
Building your Requested Budget in BRASS is a process with several steps:
 Budgeting Personal Services expenses in the SBFS (Salary & Benefits Forecasting
System) module;
 Budgeting Internal Services and other interagency agreements;
 Making other changes to the base budget (e.g., revenues, external materials &
services, and capital);
 Creating decision packages; and
 Entering performance measure information


To see a system overview of this process, select BRASS > Spreadsheet Views.



The View Selection and Display box opens. Click on ‘Show Public’ and on the
down arrow in the View Name field, and a dropdown menu appears.



Click on B> Budget Tracking {REP} and on <OK>. The spreadsheet view’s
parameter selection box opens.
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In the Funds Ctr field, select the level of your organization that you want to review,
and click on <OK>. The example above selects the Bureau of Emergency
Communications’ EC. Sections allows you to tab the data by certain variables, and
Other and Grants allow you to filter the data.



The spreadsheet view opens with the selected information. Like an Excel spreadsheet,
the view is organized in rows (commitment items or commitment item roll-ups) and
columns (different historical periods or parts of the budget process). The most
important columns in this view are:
- V51_TOTAL: Your base budget includes
o The initial Personal Services projection for permanent and limited term
positions’ salary and benefits from SBFS (V51_SBFS);
o The initial Internal Services interagencies from OMF (V51_IA_TOT);
o Adopted Budget (no CIP) external materials and services commitment
items for those bureaus that requested it (V51_BASE).
o General Fund discretionary and overhead revenues (V51_BASE)
- V52_SBFSCH: Any future changes to and allocations of positions will be
reflected in this column.
- V52_TEC_CH: Any adjustments entered via the Technical Adjustment forms.
- V52_CIP_CH: Any adjustments entered via the Infrastructure forms.
- V52_NO_DP: Base Budget. Totals all personal services from SBFS, base
budget loads, and adjustments in the Technical Adjustment and Infrastructure
forms.
- V52_DP_REQ: Any adjustments entered via the Decision Package forms.
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V52_TOTAL: Requested Budget. Totals all personal services from SBFS, base
budget loads, adjustments in budget forms, and decision packages.

In the beginning, the only populated column is V51_TOTAL, which also posts into
V52_NO_DP and V52_TOTAL. As you complete your budget development, each of
the other columns will show the results of your work. V52_TOTAL must balance
before you submit your Requested Budget (see the Budget Manual for a complete list
of technical checks that should be completed prior to budget submittal)
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Budgeting Personnel Expenses (SBFS Position Maintenance)
SBFS

SALARY AND BENEFITS FORECASTING SYSTEM

Purpose:
SBFS contains detailed information about every budgeted position and its
incumbent employee, if there is one. SBFS performs three key tasks:
1) Projects expenditures by month for salary and benefit related costs;
2) Tracks the filling and vacating of positions; and
3) Reports on filled and vacant positions.
Note: Only a few assigned bureau staff will have access to SBFS data. Contact the
designated users with any questions prior to contacting CBO.
Functions: There are five functions within the SBFS module:
1) Position Maintenance
2) Position Search and Edit
3) Reports
4) Projection Snapshots (Advanced Function; contact the administrator for additional
training and access)
5) Allocate Snapshots ( Advanced Function; contact the administrator for additional
training and access)
SBFS-Position Maintenance

Holds all position and employee data needed for position
costing. All future changes to positions and allocations
take place in this module.

Steps:
1) Open up Position Maintenance.
 Select SBFS > Position Maintenance.
 The Position Select parameter box will appear.
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Click on the Funds Ctr field and select the funds center from the dropdown menu.
You can determine how to sort the data – by position, position class, or employee
name by clicking on the radio button. In this example data will be sorted by position.




Click on <OK> and wait for the module to open.
The Position Maintenance module will open to the Employee tab.
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Notice there are five tabs in the Position Maintenance module.
 Employee tab: Contains all data pertaining to an employee such as hire and
promotion dates.



Extra tab: Includes additional data about a position, such as the HCM Org, report
class, and standard hours.



Benefits & Supplementals: All position benefits and supplemental benefits (clothing
allowance, shift pays, etc.) are contained here.



Future Change: This tab allows for calculating costs related to a future change in a
position (e.g., full-time to part-time, reclassification, etc.).



Allocation: The Allocation tab allows a position’s costs to be allocated to multiple
funds, funds centers, grants, functional areas, or funded programs.
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Note: SBFS users can modify data in white fields. The grayed out fields can only be
modified by the System Administrator.
2) Example #1: Change a position to part-time halfway through the fiscal year (Jan. 20XX).
 Go to the Future Change tab.
 In the Start field, type in 01/20XX. This indicates that the change will be calculated
beginning January of 20XX. The End field will automatically populate.
 The End date is automatically set as (12/2020) or the last month before the next future
change.
 Fill in the Sal Table, Class, and Grade fields using the existing employee information.
Do not leave these fields blank. It is important that the Sal Table and Grade are
correct for the selected classification.
 In the FTE field type in 50. This indicates a position at 50%. SBFS reflects
percentages in whole numbers. Note that the field is not large enough to show the
whole number, so click on the field to be sure you have entered the correct percent.
 In the Sal. % and Ben. % fields, type in 50. This indicates that the position will be
paid 50% of the total FTE salary, and receive 50% of the total FTE benefits.



Leave Sal. $ field blank for this example. If a salary were to be different than what is
in the position’s classification and pay range, the amount would be plugged into this
field. If you do change the salary amount, enter in the full-year salary amount. SBFS
will calculate the correct salary for the 0.50 FTE by multiplying the salary amount
times 50%.

3) Example #2: Change a position’s classification, effective October 20XX.
 Click on Add at the top of the form and a new line will appear in the Future Change
box.
 In the Start field type in 10/20XX. The end field will automatically populate.
 Fill in the appropriate Sal Table for the new classification.
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In the Class field, select the new class from the dropdown menu. Effective October
20XX, this position will be reclassified from 30000595 (Deputy Attorney) to
30000596 (Senior Deputy Attorney).
In the FTE, Sal%, and Ben% fields, type in the FTE amount that corresponds with the
position being reclassified.
Skip the Sal $ field.
Enter correct Grade from the City’s Compensation Plan for the current year.
Remember to select the proper grade that corresponds to the new position
classification. This is required in order to calculate the correct salary amount.

Click on <Save> and the module will close.

Note: A P-4 is still required to reclassify a position.
4) Example #3: Reallocate position costs to other fund centers or capital projects.
 Go to the Allocation tab for the position.
 Insert a line by clicking on <Add> at the top of the module. A new line is necessary
for each center code allocation.
 In the first date field enter 07/20XX. The other date field will automatically populate.
 The Home field indicates the percent of the position being charged to the home
master data elements. As a position is allocated to other elements, this field
automatically calculates.
 In the Percent field below the Home field, type in the percent to be charged to another
element. In this example it is 25% for both allocations. The first allocation will spread
25% of the position costs to Funded Program S00004. The second allocation will
spread 25% of the position costs to Funds Center MFOP000002. The remaining
position costs (50%) will remain in the home master data elements.



All fields in each line must be properly filled out for the allocation to be accurate.
- Funds Center: Must be a valid funds center
- Fund: Must be a valid fund
- Grant: Default is zero, but positions can be allocated to grants
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Funded Program: Default is zero, but positions can be allocated to capital
projects. Positions should not be allocated to interagency or cash transfer funded
programs.
- Functional Area: Default is zero, but this field must be updated to a valid
functional area.
- Decision Package: Default is zero, do not change. Allocating to decision
packages will result in incorrect calculations.
When finished, click on <Save> in the top right-hand corner.

Note: A 1018 form is still required to reclassify a position.
Important Information Regarding Part-Time Positions
A correction of position information – salaries and FTE percentages – through Future
Changes is typically required to correctly budget for part-time positions. Because SAPHCM does not hold FTE percentages for individual positions, the information received
for salary and FTE percent through the interface is dependent on the number of hours
worked during the most recent payperiod. The salary amount is an annualized cost based
on the rate and number of hours worked – not a full-time salary. The FTE percent is:
 0.5 FTE if the employee worked less than half time during the pay period
 0.9 FTE if the employee worked from half time to 90% time during the pay period
 1.0 FTE if the employee worked more than 90% time during the pay period
 Positions in job shares default to 0.5 FTE
To correct these positions, bureau budget staff will need to do the following:
 Enter a Future Change to correct the FTE percentage
 For Represented employees, no further change is necessary
 For Non-Represented positions, the Future Change requires a salary amount that is
equal to the full-time annual rate.

SBFS-Position Search and Edit

Allows staff to search position and employee data
and also edit through position maintenance.

Steps:
1) Find an employee in a specific Org.
 Select SBFS >Position Search and Edit.
 The Position Search and Edit parameter box will appear.
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Choose a Funds Center (required).
You can also search by entering specifications into any of the other fields:
- Class
- Category
- Position Number
- Employee Number
Searches can also be run by the employee’s first or last name. If you know the exact
spelling, choose ‘Like’; if you know the approximate spelling, choose ‘Soundex’.



For this example enter ‘AT’ in the Funds Ctr field, and then click on <Search>.



All positions in the City Attorney’s Office will appear.
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This tool allows you to search and select specific positions using different criteria
than what is available in the position maintenance selection tool. To open the
‘Position Maintenance’ screen for a specific position, select the line and click ‘Edit’,
or simply double click on the line.



Both windows can be open at the same time, allowing you to search data in Position
Search and Edit while working in Position Maintenance.
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Budgeting Interagency Agreements
Introductory Remarks
The materials below explain the technical steps to budget expenses and revenues for a bureau’s
interagency agreements, both those with OMF Internal Services and with other bureaus.
Definitions
 Service Provider: Agency that receives payment in exchange for services and/or
goods provided.
 Service Receiver: Agency that buys a service and/or goods from another agency.
 OMF Internal Service IA: OMF Internal Services provide centralized services/goods
to City bureaus based on set rates and fees. These are services that are usually capital
intensive or Citywide; therefore, one provider is most economical. OMF Internal
Services include the following:
- Bureau of Technology Services
- City Fleet
- Facilities
- Enterprise Business Solutions
- Risk Management
- Printing and Distribution
 Bureau-to-Bureau IA: This refers to all interagencies with agencies that do not
provide one of the centralized services listed above, but that do provide noncentralized services to individual bureaus.
OMF-Internal Service IAs
Note: Internal service providers will provide the system administrator with an upload file that
includes the base IAs at the master data element and commitment item level. These figures
will be loaded into V51_IA_TOT.
Steps:
1) Both Provider and Receiver bureaus should contact one another early in the budget
process to determine the services agreed upon and the amount of the IA.
2) After the internal service IAs have been loaded, the Receiver bureau should run one of
the following IA reports to ensure accuracy:
IA2. Internal Service IAs
3) Adjustments to interagencies can be made in either the Technical Adjustment or
Infrastructure budget forms. The example below uses the Technical Adjustment form.
Note: Before making adjustments to internal service IA’s, contact the Provider bureau
and notify them of the requested changes.
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Select BRASS > Budget Forms. Select one of the forms and click on <OK>.



The budget form parameter selection box will appear (in this case the Technical
Adjustments form).

FUNDS CTR

Use the dropdown menu to select a Funds Ctr (bureau).

SERIAL NUMBER

Use the dropdown menu to select ‘(New)’ or the serial number of a
form that has already been started.
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The following additional fields will display.
DESCRIPTION
STAGE
OTHER BOXES



Enter a description for the form.
Select stage A (only option).
Six other boxes appear on the screen but are not used for this form.

Click on <OK>. The form will open.

4) Load the adjustments into the form.
 Determine the master data elements where the adjustments are taking place, including
the funded program. All adjustments to interagencies must have a funded program
assigned.






When reallocating interagency costs, remember to reduce the interagency expense
from the original load.
When increasing or decreasing an interagency, remember that the amount loaded into
the form is the change amount and will be added/subtracted to the original amount
loaded in column V51_IA_TOT.
In the Justify column, identify the unit type and quantity requested. If more narrative
space is needed it can be included in the Justification tab.
Click on <Save>, and the form will close.

5) Run the IA2. Internal Service IAs report to ensure that the adjustments were loaded
correctly and that it balances with what the Provider bureau has entered. Contact the
Provider bureau to resolve any differences.
 Select BRASS > Reports. Select IA2. Internal Service IAs. Select the funded
program that the adjustments were made to (leave the default of City if you want to
check all of your IAs) and V52_TOTAL (you can leave it at the default of
V55_TOTAL if you wish) in the Columns field.
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Click on <OK>. The report appears.
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Bureau-To-Bureau IAs
Steps:
1) Both Provider and Receiver bureaus should contact one another early in the budget
process to determine the services agreed upon and the amount of the IA.
2) Budgeting bureau-to-bureau IAs is very similar to budgeting internal service IAs. Follow
the same steps as above with the following exceptions.
 Unlike the internal service IAs, bureau-to-bureau IAs have not been preloaded into
the V51_IA_TOT column. All interagency amounts must be entered into budget
forms assuming a starting point of zero.
 Use report IA1. Bureau to Bureau IAs to check if you are balanced between provider
and receiver. The report functions in the same manner as the IA2 report.
 In the Justify column, type in the reason for the IA – be specific. If more narrative
space is needed it can be included in the Justification tab.
Cash Transfers
Steps:
1) Both the cash sender and cash receiver bureaus should contact one another early in the
budget process to determine the amount of the transfer.
2) Budgeting cash transfers is very similar to budgeting IAs. Follow the same steps as above
with the following exceptions.
 Cash transfers have not been preloaded into the V51_IA_TOT column. All cash
transfers must be entered into budget forms assuming a starting point of zero.
 Use report IA3. Cash Transfers to check if you are balanced between sender and
receiver. The report functions in the same manner as the IA1 and IA2 reports.
 In the Justify column, type in the reason for the transfer – be specific. If more
narrative space is needed it can be included in the Justification tab.

For more information about how to properly budget for IAs and cash transfers, please see the
Budget Manual on the CBO website
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Completing the Base Budget (Technical Adjustment Form)
Introductory Remarks
Purpose:

Adjust a bureau’s budget for technical reasons that do not require Council input.
Technical adjustments tend to be “housekeeping” transactions.

Note: There are two types of technical adjustment forms. The Technical Adjustments form
parameter box allows selection by bureau only. The inside of the form will allow entry in fund
centers within that bureau, and any other master data element in the other fields. The Simple
Tech Adjustments form parameter box allows selection by a single fund center, fund, and
functional area. The inside of the form will default the selected fund center, fund, and
functional area in each of the lines, and will allow any other master data element in the other
fields.
Steps:
1) Open one of the technical adjustment forms.
 Select BRASS > Budget Forms. Click on 4. Technical Adjustments and on <OK>.



The parameter selection box will appear.
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FUNDS CTR
SERIAL NUMBER

Use the dropdown menu to select a Funds Ctr (bureau).
Use the dropdown menu to select ‘(New)’ or the serial number of a
form that has already been started.

The following additional fields will display.
DESCRIPTION
STAGE
OTHER BOXES



Enter a description for the form.
Select stage A (only option).
Six other boxes appear on the screen but are not used for this form.

Click on <OK>. The form will open.

2) Load the entries into the form.
 Every line is required to have a funds center, fund, functional area, and commitment
item (no zeros).
 The funded program should be ‘0’ unless the entries involve IAs or cash transfers.
 The grant field should be ‘0’ unless the entries involve grants.
 Columns
- V51_TOTAL: Displays data when you enter a line that contains internal
service IAs, personal services, base budget external materials and services, or
GF discretionary & overhead amounts.
- V52_TEC_CH: Data entry column. All technical adjustment entries for the
Requested Budget should be entered in this column. As the budget process
moves through the stages, this column will change to V53_TEC_CH,
V54_TEC_CH, and V55_TEC_CH respectively, and the previous versions
column will disappear from the form. Please note that this column is an
adjustment column. Only enter the change amount from the previous versions
total, not what you want the total to be for that version.
- Justify: Enter in notes pertaining to that particular line item.
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Click on <Apply> (or hit the <Enter> key) to save the entries. This will save the data
and keep the form open. TIP: It is particularly useful to do this frequently; during
peak usage periods so as to avoid losing data to the occasional ‘Primary Key
Contstraint’ error. This error occurs when multiple users request a new line from the
database simultaneously.

3) Provide narrative for the changes by using the Justification tab.
 Click on the Justification tab near the top of the form.




In the space provided, enter the desired narrative that explains the entire form. Text
can be cut and pasted from Word documents. The Justification tab pertains to the
whole form, whereas the Justify column pertains to individual lines within a form.
Once the narrative has been completed, click on <Save>. This will save the data and
close the form.

IMPORTANT: As noted above, lines in technical adjustment forms should NOT be
deleted. As the budget process moves forward, columns are hidden in the form.
Deleting lines will delete these earlier entries (although it will not delete the data in the
system).
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Developing Capital Budget (Infrastructure Form)
Purpose:

Use this form to enter expenditures and revenues for capital projects. Bureaus
are not required to enter revenue sources by project. Patternstream will only
display the expenditure amounts in the CIP section of the budget documents.

Note: There are also two types of infrastructure forms. See the note above under technical
adjustment forms for an explanation of the differences between a standard form and a simple
form.
Steps:
1) Open one of the infrastructure forms. Entry into the infrastructure forms is similar to entry
into the technical adjustment forms, with the following exceptions.
 The funded program field should include a project number.
 Columns
- Prior: Enter expenditures from the prior fiscal year only. Prior year
expenditures can be entered in one line for each project. Remember that the
life-to-date actuals for the project (minus the prior fiscal year) are already
loaded into BRASS. Users should run a report or spreadsheet view to identify
what has already been populated in this column before entering amounts in the
budget form.
- V52_CIP_CH: Data entry column. All capital related entries for the
Requested Budget should be entered in this column. As the budget process
moves through the stages, this column will change to V53_CIP_CH,
V54_CIP_CH, and V55_CIP_CH respectively, and the previous versions
column will disappear from the form. Please note that this column is an
adjustment column. Only enter the change amount from the previous versions
total, not what you want the total to be for that version. To help determine
how much is already budgeted, a total column is provided for display
purposes.
- Year 2-5: Enter out-year financial data pertaining to the project. Out-year
expenditures can be entered in one line for each project.
- Justify: Enter in notes pertaining to that particular line item.
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Using Info Edit for Decision Package, Project, and Performance
Measure Information
Info Edit can be used both for data entry for text and non-financial parameters, and as an online
reference tool.
To access Info Edit, select BRASS > Info Edit.
Using Info Edit for Decision Package Information
The BRASS System Administrator creates a set of decision packages for each bureau. Use Info
Edit to assign a descriptive name to a decision package and provide explanatory narrative.
(Depending on your bureau, you may do this yourself or have a decision package assigned to you
by bureau budget staff.)


Select BRASS > Info Edit. Select ‘Dec Pkg’ from the dropdown menu.



The Dec Pkg: Info Edit box appears. Select a decision package, and click on <OK>.
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The Info Edit entry box appears. The decision package code is displayed in the Dec
Pkg field.

Info Tab
The fields for data entry are:
 Name: The name given to a decision package will be used in all reports submitted to
Council. Names should be clear and concise, identifying what the package includes.
 Budget Prog: Bureaus need to identify the budget program affected by the decision
package in the ‘Budget Prog’ field. Please use the name of the program used on your
Program Summary templates submitted with your Requested Budget. If the package
involves multiple programs, please choose the program that is the most affected.
 Scenario 1-8: Used to include or exclude the decision package in various scenarios.
If you choose to utilize this feature, select ‘Y’ to include the decision package in a
given scenario or ‘N’ to exclude it. Scenario 1 should always be set to ‘Y’ so one
scenario includes all decision packages. To view the scenarios, run the BRASS report
D1. Decision Package Scenario.
 Mayor Y/N: For CBO use only.
 Report: Defaults to ‘INCLUDE’. If this is set to ‘EXCLUDE’, the decision package
will not show up in various decision package reports. Decision packages should only
be set to ‘EXCLUDE’ if there is no budget assigned to it.
 Priority: Bureaus need to identify the priority of the decision package, with #1 being
the highest priority. A #1 priority cut should be the cut the bureau is most willing to
take, and a #1 priority add is the add the bureau needs the most. Bureaus should rank
the packages from highest to lowest priority within each of the decision package
types. In other words, each bureau can have a #1 priority cut, #1 add, and #1
realignment. Bureaus cannot equally rank packages within a decision package type
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(no multiple add packages with a #1 priority ranking).
Type: Bureaus need to flag each decision package with a type. For more information
on the types, please see the Budget Manual.

Text Tab
The fields for data entry are:
 Text 1: Bureaus enter explanatory narrative for the decision package in the text 1
field. This narrative is published in the Decision Package Summary report, which is
part of the bureau’s Requested Budget submission.
 Text 2: Bureaus enter the expected results of the package in the text 2 field. The
expected results section should include any changes to performance or output
measures affected by the package. This narrative is published in the Decision Package
Summary report, which is part of the bureau’s Requested Budget submission.


Click on <Save> to save your work.

Using Info Edit for Project Information
Bureau budget analysts enter project information through the use of Info Edit.


Select BRASS > Info Edit > Fnd Prgm, and click on ‘OK.’
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The Fnd Prgm: Info Edit box appears. Select a funded program (project), and click
on <OK>.



The Info Edit entry box appears. The project code is displayed in the Fnd Prgm field.
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Info Tab
There are a number of fields that are either populated by the interface with SAP or by the user.
Please note that all fields identified as being populated by an SAP interface will be overwritten
with every upload from SAP. Changes made directly in BRASS to these fields are only
temporary. Please make all adjustments to these fields in SAP and wait for the next upload to
view the changes in BRASS. For an updated list of all the fields as well as definitions and
guidelines for their use, please see the Budget Manual.

Page 39 of 75

BRASS TRAINING MANUAL-OPERATING

Text Tab
 Text 2: Populated by user in BRASS. Includes the narrative used to describe the
project for reporting and budget document publishing. Narrative for existing projects
(used in the budget last year) should already be populated and edited for content and
grammatical errors. If the project is new, the text 2 field needs to be populated with a
description of the project.


Click on <Save> to save your work.

Using Info Edit for Performance Measure Information
Bureau budget analysts enter some performance measure information through the use of Info
Edit.


Select BRASS > Info Edit > FuncArea, and click on ‘OK.’
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The FuncArea: Info Edit box appears. Select a performance measure (they start with
the bureau code and are located at the end of the list), and click on <OK>.



The Info Edit entry box appears. The performance measure code is displayed in the
FuncArea field.
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Info Tab
SAP does not provide any information via an upload for performance measures. All information
is stored directly in BRASS and must be entered by the user. The fields for data entry are
discussed in detail as part of the Budget Manual.

Text Tab
 Text 1: Enter an optional description of the measure, or any other details that may be
helpful to CBO when analyzing the measure. This field is not printed in the budget
documents or any BRASS reports.
 Text 2: For measures to be graphed, include a brief explanation of what the graph
depicts (used in budget documents).
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Creating Decision Packages
Introductory Remarks
The BRASS System Administrator will set up a series of “blank” decision packages for each
bureau to assign and use. These will be titled generically, e.g., PK_01 for the first decision
package in the series for the Parks Bureau. If a bureau needs more blank decision packages than
are currently available, contact the System Administrator.
Your bureau will have its own process for how its program and/or budget staff will develop
decision packages for internal review and approval. Please check with your bureau’s budget staff
for specific instructions about how your bureau will assign and develop decision packages.
What is a Decision Package?
In general, a decision package is required for either of the following actions:



Change revenues or appropriations, including reallocating between programs
Change Council-authorized positions

Other changes to a bureau’s starting point budget can be made in BRASS through SBFS and
capital and technical adjustment forms.
The purpose of decision packages in City budgeting is to present all budget requests/adjustments
that are appropriate for Council deliberation and decision making.
Create or Edit a Decision Package Budget Form
Purpose:

Use this form to create a decision package and move it through the various
stages in the decision-making process

Select BRASS > Budget Forms. Click on 3. Decision Package and on <OK>.
Note: There are three types of decision package forms. The Decision Package form parameter
box allows selection by bureau only. The inside of the form will allow entry in fund centers
within that bureau, and any other master data element in the other fields. The Simple Decision
Package form parameter box allows selection by a single fund center, fund, and functional
area. The inside of the form will default the selected fund center, fund, and functional area in
each of the lines, and will allow any other master data element in the other fields. The
Decision Package (LT FTE) form is constructed the same way as the Decision Package form,
but the FTE and dollar amounts from the position tab default to the one-time column instead
of the ongoing column.
Steps:
1) Open one of the decision package forms.
 Select BRASS > Budget Forms. Click on 1. Decision Package and on <OK>.
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The parameter selection box will appear.

DEC PKG
FUNDS CTR
SERIAL NUMBER

Use the dropdown menu to select a decision package number.
Use the dropdown menu to select a Funds Ctr (bureau).
Use the dropdown menu to select ‘(New)’ or the serial number of a
form that has already been started.

The following additional fields will display.
DESCRIPTION
STAGE
OTHER BOXES

Page 44 of 75

Enter a description for the form.
Select stage A (Requested Budget stage).
Six other boxes appear on the screen but are not used for this form.

BRASS TRAINING MANUAL-OPERATING



Click on <OK>. The form will open.

Note: If a decision package has been set up in Info Edit by your bureau, you will see the name
of the decision package in the dropdown menu. Unassigned decision packages will still show
with the generic title ‘Decision Package’. To see all of the decision package budget forms
created for your bureau, select your Funds Ctr, leave Dec Pkg blank, and use the scroll bar in
Serial Number to view the names of all the budget forms.
2) Load the entries into the form.
 Every line is required to have a decision package, funds center, fund, functional area,
and commitment item (no zeros).
 The funded program should be ‘0’ unless the entries involve capital projects, IAs, or
cash transfers.
 The grant field should be ‘0’ unless the entries involve grants.
 Columns
- Ongoing: Enter requested adjustments that are ongoing in nature.
- 1-Time: Enter requested adjustments that are one-time in nature.
- Year 2-5: Enter out-year financial data. Data in these columns is only
required for capital projects unless you are requesting General Fund
discretionary for a multi-year decision package.
- Justify: Enter in notes pertaining to that particular line item.




Remember that all decision package forms must balance before they can be saved. To
balance a form, enter a revenue source or offsetting expenditure.
Click on <Apply> to save the entries. This will save the data and keep the form open.

3) Use the Position tab to add or delete positions.
 Click on the Position tab near the top of the form.
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Add a line by clicking on <Insert>



Every line is required to have a decision package, funds center, fund, functional area,
and commitment item (no zeros).
Fund Prgm: should be ‘0’ unless the position is assigned to a capital project.
Grant: should be ‘0’ unless the entries involve grants.
Class: Select the class (job number) from the dropdown menu
Step: Choose a valid step (pay scale level) for that class. You will receive an error
after clicking the <Calc> button if an invalid step is used for the specified class. The
system will calculate the position at bottom step if left blank.
Category: It is critical for each position record in a decision package budget
form to have a valid category (pay scale area). Salary amounts from the
position tab will be posted on the General Tab in separate commitment
items for limited term, part-time, and full-time positions, depending on the
category used in the position tab. The position summary table in
Patternstream will also pull the type of position from the category
assignment. Categories are based off of bargaining units, with separate
categories for limited term, part-time, and full-time requests.
Start: Leave blank and it will default to July 1 of the upcoming fiscal year. If you
have a specific start date, enter it here. SBFS will calculate the number of months
between the start and end date and multiply that by the total FTE. If you enter in a
start date of January 1st, an end date of June 30th, and an FTE of 100%, the system
will calculate the FTE and position costs assuming a 0.50 FTE (100% FTE for ½ of
the fiscal year).
End: Leave blank and it will default to June 30 of the upcoming fiscal year. If you
have a specific end date, enter it here.
FTE: Enter the total full-time equivalent for the position as a percent (e.g., a position
that is 0.80 FTE would be entered as 80). Use positive integers for adds, negative for
cuts. Use one line per position. This makes tying out the changes with the HCM
system considerably easier since there will be a one-to-one relationship between
positions added or eliminated with position numbers.
Cnt: Enter the total number of positions (e.g., a position that is 0.80 FTE would be
entered as 1). Use positive integers for adds, negative for cuts.
Salary: Leave this field blank, and the total salary is calculated from the class and
step selection. Classes on a grade table will calculate at the bottom of the range. If
you want to override the step selection, enter an annual salary in this field. Use
positive integers for both added and deleted positions.
Cost: Displays position cost based on the specifications made in the fields above.
Cost includes salary and benefits for the budget year only.
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The example below would add one limited term office support specialist position at
the entry level (note the DTLT distinction to identify the position as limited term).



The example below would delete one part-time office support specialist position with
a known salary of $32,000 per year (note the DTPT distinction to identify the position
as part-time, the step field is left blank, and the salary field is populated).

Note: When cutting a specific position, you can manually enter the exact salary costs, but you
cannot enter specific benefit costs. The system calculates benefits based on a certain set of
assumptions. If you want to cut a specific benefit amount, allow the system to calculate the
dollars, and then make any adjustments needed on the General Tab.



Click on <Calc> when you are ready to calculate the costs of the position.
Once calculated, the total costs of the position will be reflected on the General tab.

4) Provide narrative for the changes by using the Justification tab.
 Click on the Justification tab near the top of the form.



In the space provided, enter the desired narrative that explains the entire form (not
required). Text can be cut and pasted from Word documents. Do not use the
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Justification tab to summarize the decision package for the City Budget Office and
City Council. For that narrative, use the text box available through Info Edit.
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Entering Performance Measure Data
The performance measure tasks and how to do them in BRASS are summarized below.
Create a new performance measure

Contact your City Budget Office analyst

Delete old performance measure

Contact your City Budget Office analyst. The measure
will be archived, not deleted, but it will no longer appear
on your entry form or reports.
Contact your City Budget Office analyst
Updated via BRASS Info Edit screen for functional area

Change a measure’s name
Move a performance measure to a
new/different program
Manage the printing or graphing of a
performance measure
Enter data values for a performance
measure
Report on performance measures

Updated via BRASS Info Edit screen for functional area
See this section.
See this section.

Entering Data Values
Steps:
1) Open the performance measure entry form
 Select BRASS > Performance Measures > Values. The Select Controlling Org box
opens. Select your bureau in the Controlling Org field, and click on <OK>.

2) Load the performance measure values into the form
 Enter all values as numbers, with or without decimals. For example, enter 75% as .75.
 Do not use commas or other formatting
 If a value is not available for a given column, enter 999999 (this will be displayed as
‘NA’ in the budget document).
 Columns
- PM_GOAL: Entries are posted to V52_TOTAL and should reflect what can
or cannot be accomplished within the bureau’s total Requested Budget
(including all decision packages)
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-




PM_BASE: Entries are posted to V52_NO_DP and should reflect goals that
can be accomplished within a bureau’s base budget or CAL
CY_REVBUD: Entries should reflect year-end estimates for the current year.
PY1_ACTUAL: Entries should reflect actual values from the last fiscal year.

Click on <Save> to save your work and close the form.
To view your performance measure entries, run BRASS report PM1 (or PM2 for
OMF bureaus). Performance Measures. The report will include formatting, program
and type assignments, and other historical data that is not displayed in the data entry
form.
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Part IV – Using BRASS Reporting/Viewing Tools
This section shows how to use the reporting and viewing tools in BRASS to see the
results of your work or to analyze the data. This includes:
Reports
Standard Spreadsheet Views
Creating and Editing Personal Spreadsheet Views
Comparing Reports and Spreadsheet Views
Advanced Spreadsheet Views
Comparing Advanced and Standard Spreadsheet Views
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Reports
1)

Start from the BRASS home screen.


Select BRASS > Reports.

2)

You’ll see the Report Selection box.

3)

Select A1. Expenses (FC/Fund). Click on <OK>.

4)

This brings you to the parameter selection box of the report, where you make selections
that determine what data is retrieved in the report. The Sub-Title field is an optional field
in most reports that is available to the user for whatever purpose they deem useful. Fund
Center is a required field. Other fields may also be available (in this example Fund) to
further limit the data retrieved in the report. The Columns selection has defaults, but in
most cases the columns can be changed (if the box is white, it can be changed).

5)

Once you have completed your selections, Click <OK> to generate the report.
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6)

Reports can be updated without rerunning them by clicking the ‘Refresh’
button on
the BRASS menu bar (or File > Refresh). Reports can be viewed onscreen or printed, but
they cannot be exported to Excel (except grid reports).

7)

To print reports, select File > Print

8)

You will see the print parameters screen.

9)

The print parameters screen allows you to customize your printing:
 Select your printer
 Select page orientation
 Select page margins
 Select number of copies
 Select specific pages to print
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Standard Spreadsheet Views
Spreadsheet views display information from BRASS in a format similar to a spreadsheet.
Spreadsheet views can be used to display information:
 For different parts of the organization – e.g., for just your section or the whole bureau
(depending upon your level of security access)
 At different levels of detail
 From more than one budget form
 In a format that can be exported into Excel
Columns and Lines
In BRASS, Columns represent stages and decision points in the budget process such as the Base
Budget, Requested Budget, Mayor’s Proposed, etc. Columns can also “multi-post” – meaning,
entries in one column are automatically added to another. For example, the requested decision
packages column is included in the Requested Budget column and is also rolled forward to the
Mayor’s Proposed, Approved, and Adopted Budget columns.
Lines represent line-items in the budget, such as full-time personnel costs, overtime, professional
services, FTE, etc. Most lines are commitment items (e.g. 511100 = full-time employee costs).
There are also lines representing groups of commitment items (e.g. EMS=all external materials
& services accounts).
Together Columns and Lines make up the two dimensions of the spreadsheet in a spreadsheet
view.
Public and Private Views
Public views have been set up by the System Administrator for all BRASS users. Click Show
Public on the View Selection and Display Box to see a drop down menu of these views.
Private views may be created by any BRASS user for personal use. This will be covered in a
later section.
Accessing Spreadsheet Views
1) Select BRASS > Spreadsheet Views.
2) The View Selection and Display window will appear.
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3) Check the Show Public box to see Public Views that are available to you. If you do not
select this box, only your personal views will display in the dropdown list. Click on the down
arrow in the View Name field to scroll through the list of views.

4) Select view you wish to run from the dropdown list. For purposes of this illustration, select
B> Budget Tracking {REP} from the list. Then click on <OK>. A View Selection and
Display screen will appear as shown below.
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5) There are four sections to this screen. Your entries in these fields determine the data your
spreadsheet view will extract from the database.
 Funds Ctr: Defines the bureau/division/fund center for the view. This field must be
populated for the view to run.
 Sections: Defines the data element to be used as tabs in the view, and the level at
which the tabs are displayed.
 Other: Can be used to limit the retrieved data to a single functional area, fund,
funded program, or decision package. The data can also be retrieved for the
hierarchical groups for each of these elements. Select “All” if you do not want to limit
the search.
 Grants: Can be used to select individual grants or ranges of grant codes.
6) Select the Funds Ctr to include in the view.



The Funds Ctr selection can be made at the City, bureau, division, or fund center
level.

7) Select the Sections to include in the view.
 If you select “None”, the view will NOT include separate tabs (spreadsheets). There
will be one tab with a total of the entire Funds Ctr as selected above.
 By selecting one of the master data elements, you can separate the data in your view
using tabs like an Excel spreadsheet. In the example below, Funds Ctr was selected.
Selecting one of the elements will open a Level and Type field.
 Level refers to the level of the hierarchy at which you would like the report sections
to be tabbed. In the example below, selecting level ‘4’ means that the view will create
separate tabs for each Fund Center within the Bureau of Development Services
(DS). Level ‘3’ would create separate tabs for each Division.
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Type refers to the types of hierarchical levels to include in the report. Always choose
Both.

8) The Other selection box allows you to specify an individual or group of functional areas,
funds, funded programs, or decision packages to report on. To expand on the example above,
you could set up the view to see how the costs of a single decision package were spread
across multiple funds centers. Using the same setup above for Funds Ctr and Sections
selections, select the radio button for Dec Pkg in the Other section, and choose the desired
decision package from the dropdown menu.
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The resulting view would only include data for the specified decision package, and
would have tabs for each fund center within the Bureau of Development Services.
The Sections and Other selection boxes can be used in tandem to slice and dice data
in numerous ways.

9) The Grants selection box allows you to specify an individual or range of grant codes to
include in the view.
 Click on the Select radio button. A new screen area opens as shown below.



To select the grants to include in the view, click on the down arrow in the
Classification box to open a list of all relevant grant codes. Grants can be selected
individually or by using a range (e.g. EM000000-EM000005).

10) Once you have selected the view parameters, click on <OK> to create the spreadsheet view.

Note: While the view is executing, the system will provide you with status updates in the lower
left-hand corner of the screen together with a progress bar in the lower right-hand corner of
your screen.
Spreadsheet View Appearance
You can change some aspects of the appearance of public spreadsheet views:
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Removing the Screen Split
The view will open with a title split that functions like a scroll lock. On the left are columns that
are duplicative of the first few on the right. To remove the title split from your view:
 Click your mouse between the two bottom scroll arrows.
 When the mouse pointer changes to .¦., drag the vertical line to the far left edge. The
left-hand duplicated columns will disappear.
Changing Column Widths
 Move the mouse to the very top right-hand edge of any column. The mouse shape
will change to .¦. and a vertical line will appear.
 Click and hold the left mouse button.
 Now drag the line to the right or left to make the column wider or narrower.
 When the column is the desired width, release the mouse button.
Moving a Column
 Move the mouse to the thin empty band above the column name you want to move
and single click the left mouse button. The entire column will change color.
 With the mouse still at the top of the column, click and hold the left mouse button. An
indicator will appear at the top and bottom right-hand edge of the column.
 Drag the mouse to the new location and release the mouse. The column will move to
the new location.
Zooming to Detail
The <Zoom> button on a view allows you to drill down to the detailed information that adds up
to the number in the selected cell.
 Click on the cell that you want to zoom in on.
 Click the <Zoom> button in the upper left-hand corner.
 You may see a message like the following:

Note: This message informs the user that a model (calculation set up by the user) has been set
up within the spreadsheet view. Any numbers that are a result of that model will not have an
audit trail (information to zoom in on). Models may include net revenue and expenditure
lines, subtotals, etc.


In different spreadsheet views, you may also see one of the following boxes to zoom
to detailed objects or columns:
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Choosing ‘Expand to Detailed Objects’ will give you the six-digit commitment item
detail (e.g., 511100) for the line that you zoomed in on. Choosing ‘Expand to
Detailed Columns’ will give you the data broken out by the columns that the data was
posted to. For example, if you zoom in on a column such as V52_TOTAL (Requested
Budget), you would see information from technical adjustment columns, decision
package columns, and base budget columns separately. For the summary level detail,
do not check this box.
The result of the zoom will provide the details behind the number that was zoomed in
on from the spreadsheet view.

A line of data within a zoomed view may also be zoomed in on again to show further
information, such as the form that the data came from, the audit trail, and the user
who made the entry. This feature may only be used, however, when the data was
entered through a budget form. Simply select the line of data you wish to view, and
click on <Zoom> again.
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Exporting a View to Excel
The spreadsheet view and each level of the zoom feature can be exported into an Excel
spreadsheet or text file. To export a view, select File > Export. Select a destination, name, and
file type. Please note that only the selected tab of a view will be exported.
Printing a View
Once a view is displayed on the screen and modified, it can be printed to any printer currently
defined through your Windows Control Panel. Select File > Print.
Refreshing a View
Views can be updated without rerunning them by clicking the ‘Refresh’
BRASS menu bar (or File > Refresh).
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Creating and Editing Personal Spreadsheet Views
In addition to running public spreadsheet views, you can create your own spreadsheet views.
Creating personal spreadsheet views allows you to use the modeling features of BRASS. Unlike
public spreadsheet views, these views will only be available to the user who created them.
Creating a Spreadsheet View



To create a spreadsheet view, select BRASS > Spreadsheet Views.
The View Selection and Display window will appear.




Click on <New View>. A New Name window will appear.
Give your view a descriptive name (up to 30 characters, spaces are NOT allowed, use
_ instead), and click on <OK>.



The Edit Spreadsheet View screen will appear:
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Line and Column Selection












When you use a public spreadsheet view, the lines and columns displayed in the view
have been selected for you. When you create your own spreadsheet views, you must
identify the lines and columns to be displayed in the view.
To select lines, click the dropdown arrow next to the Line Selections field. The list of
commitment items available for selection will appear.
Highlight a line in the Line Objects box that you want for your view and click
<Select> to place your selections in the Line Selections field. Repeat process to add
more lines.
Ranges of lines can be chosen by selecting the beginning and ending lines and placing
a hyphen with no spaces between them. For example: 511100-521000.

If you want summary lines to appear to simulate totals, you must select them also
(e.g. 511, PERSONNEL, E).
Selected lines will appear in your view in the order in which they appear in the Line
Selection field.
To create white space (blank lines) in your view, enter an exclamation point “!”
between the lines you want to put space between.
To have the view display the Funds Ctr description at the top of each section of the
spreadsheet, enter a double exclamation point “!!”.
To have a line of text, enter an exclamation point followed immediately with no
spaces by the text. For example, “!TOTAL_M_AND_S”. Note that spaces are
replaced with underscores (_) to keep the text together.
When you have finished selecting your lines, click the <Close> button.
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Spreadsheet Column Selection
The columns of data that will appear on a view are controlled through the Column Selections
portion of the Edit Spreadsheet View screen. Selecting columns works identically to selecting
lines. You may select one column, multiple columns, or a range of columns.


To access the dropdown menu, click on the Column Selections arrow, and a
selection box will open similar to the following:



To add an individual column, type the column name in Column Selections, or single
click on the object then single click on <Select>, or double click on the desired
object.
A range of columns may be included. To enter a range, type the beginning column
followed by a hyphen ( - ) and the ending column.
When you have finished selecting your columns, click the <Close> button.




Other Options




Spreadsheet views can be created in “tabbed” or “report” formats. Tabbed format
replicates an Excel spreadsheet with individual tabs (pages) for each section of data
retrieved. Report format lists the individual sections one after another on a single
page (you must scroll down to see all sections of the data retrieved). The tabbed
format is the default, select Report View to get the report format.
The setup also includes different options for displaying numbers, coloring schemes,
formatting, and an option for “Zero Blank”. If this item is NOT checked, the view
will return all commitment items in the view even if there is no data in them. It is
advisable to check this option so that you only see the commitment items that hold
budget information.
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Creating Spreadsheet Models


To build a new model (i.e., a calculated line or column), select <New Model> from
the Edit Spreadsheet View screen. The Edit Model window appears.





Models use the lines and columns specified in the Edit Spreadsheet View setup
screen. If the column or line is not in the setup screen, it cannot be used in the model.
To insert a model command, click on <Insert>, and a new line will be inserted
immediately below the location of the hand pointer.
The example below illustrates how to set up a model that takes the difference between
Expenditures (E) and Revenues (R) for each column selected in the setup screen. The
‘DIFF’ line is a commitment item that does not hold any budget or actuals data, it is
strictly for use in models.



Other commitment items available for modeling are shown below.
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Models can be set up to calculate off of columns, lines, specific cells, or even numeric
values. The calculations include adding, subtracting, multiplying, and dividing.
Contact your CBO analyst if you have any questions about how to create a specific
model.
Click on <Save> to save your model commands before returning to the setup screen.

Saving Spreadsheet Views


When you have finished with the spreadsheet view setup, click on <Save> to save the
view.

Running Your Spreadsheet Views



Select your view from the View Selection and Display window.
Select your parameters and click on <OK>.

Editing Spreadsheet Views


To edit a spreadsheet view after it has been saved, click on <Edit View> from the
View Selection and Display window.

Deleting Spreadsheet Views




Select the spreadsheet view you wish to delete from the View Selection and Display
window.
Click on <Edit View>. The Edit View window appears.
Click on <Delete>. The system will ask:
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To confirm the deletion of this view, click on <Yes>. To retain the view, click on
<No> and you will be returned to the Edit View screen.

Copying Personal Spreadsheet Views








Select the spreadsheet view you wish to copy from the View Selection and Display
window.
Click on <Edit>. The Edit View window appears.
Click on <Copy>. The system will respond with a New Name box.

Enter a name for this view up to 30 characters in length (up to 30 characters, spaces
are NOT allowed, use _ instead).
Click on <OK>. The system will copy the existing view including any associated
model to the new view name. The system returns control to the Edit View screen for
the new view.
Make any changes you wish to the copied view and click on <Save> when you have
finished.
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Comparing Reports and Standard Spreadsheet Views

Standard Spreadsheet Views vs. Reports
Issue
Want to be able to customize the
report

Report

NO, however you can
choose the columns
you wish to view.
Want to be able to export results to Only one type of report
Excel for analysis
has this capability
(Grid Export reports).
Totals by master data element
Automatically rolls up
totals by various
grouping levels (Funds
Center, Fund, Funded
Program, etc.)
Output format
Formatted output with
headings, page
numbers, dates, etc.
Details
No <Zoom> feature.
System Administrator
decides how data is
displayed in the report
setup.
Doesn’t require a lot of
Bottom line
setup, but users don’t
have much control over
output. Reports can
only be set up by the
System Administrator.
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Standard Spreadsheet View
YES – Customize existing or
build your own.
YES – All

Requires user to choose a
reporting level in the Sections
box to total by various grouping
levels
Spreadsheet-like but can be
sectioned into tabs by master
data element.
User can <Zoom> to see details
of a particular cell (audit trail).
Data can be sliced and diced
according to the user’s
specifications.
Requires some setup, but users
have lots of control over output.
Users can also create their own
views.
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Advanced Spreadsheet Views
Advanced spreadsheet views (ASVs) are very similar to basic spreadsheet views in that they
consist of lines and columns that can be easily viewed by the user. They differ from basic
spreadsheet views in that they allow the user to specify what data elements are represented by the
lines and columns (e.g., lines may be funded programs, and the columns may be commitment
items). Additionally, ASVs allow multiple data elements (funds center, fund, functional area,
funded program, decision package, grant, and commitment item) to be used in the view
definition, while standard views only allow three elements to be specified.
Creating an Advanced Spreadsheet View



To create a view, Select BRASS > Advanced Spreadsheet Views.
The View Selection window will appear.



Click on <New>. A New Name window will appear.



Give your view a descriptive name (up to 30 characters, spaces are NOT allowed, use
_ instead) and click on <OK>. A View Selection window will appear.

Selection Tab
The Selection tab is used to define which master data elements are used in the ASV. By selecting
one of the elements, the user can define what data will be returned in the ASV.
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To enable an element, click the checkbox next to the element’s name.
The Seq field is used to identify the position of the selected element relative to the
other elements that appear in the ASV. The element positioned first in the ASV is the
one that will be tabbed for non-report format views.
The Level field is used to identify the level at which the data within the ASV is
displayed.
The Type field is used to identify the type [Consolidating (e.g., bureau) or Nonconsolidating (e.g. funds center)] of values returned for the Level specified. Select
‘Both’ if you are unsure of the type.
The Table field, where applicable, is used to identify the table that an element uses to
obtain values for inclusion in the ASV. This functionality is not being used in the
current setup of BRASS.
The Selection box is used to define the data for each element that will be returned in
the ASV. Values can be entered individually or in ranges.
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Objs & Cols Tab
The Objs & Cols tab is used to identify the commitment items and columns used in the ASV.






At least one commitment item and column must be identified.
Similar to standard spreadsheet views, the fields allow multiple values listed
individually or in ranges.
A single exclamation point (!) will cause a blank row or column to be displayed at the
position it is inserted in the list.
A single exclamation point followed immediately by text in the Commitems field
will cause the entered text to be displayed at the position it is inserted in the list.

Presentation Tab
The Presentation tab is used to define the look of the ASV.
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This tab allows the user to format the view. Users can change the width, text color,
font style, and even add subtotals for each element.
Zero Blank: suppresses commitment item rows that have no data in them. Users
should always check this box when creating ASVs.
Report View: causes all data to be presented in a scrolling list. If not checked, the
ASV will include tabs at the level of selection for the first element (identified by the
Seq in the setup).
The Column section allows the user to display any master data element or
commitment item as columns in the ASV. In cases where something other than
columns is defined as the ASV Columns, only one data column can be identified on
the Objs and Cols tab. For example, if you selected Fund to be displayed as
columns, the ASV would return a view that would have commitment items as rows
and funds as columns. The amounts would reflect the data column selected in the
Objs and Cols tab. This functionality can be a very powerful tool once you
understand how to setup the structure.

Numerals Tab
Allows formatting of the data amounts returned in the view. This tool works the same as it does
in standard spreadsheet views. Click the <Test> button after entering parameters to see how
result data will look.

Model Tab
This tool works the same as it does in standard spreadsheet views. Information and instructions
for creating ASV models can be found in the Creating and Editing Personal Spreadsheet
Views section of this manual.
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Note: if an element is used as a column in the view, then setup of a model must be altered to
reflect this change (e.g., if commitment items are chosen to be displayed as columns, then the
setup in the model will have those commitment items prefixed with “Col” rather than “Line”).

Saving Advanced Spreadsheet Views


When you have finished with the view set up, click on <Save> to save the view.

Running Your Spreadsheet Views



Select your view from the View Name list.
Select your parameters and click on <OK>.

Editing Spreadsheet Views


To edit an ASV after it as been saved, select the view you wish to edit, and make your
changes. Unlike standard spreadsheet views, there is no separate Edit View window.

Deleting Spreadsheet Views



Select the advanced spreadsheet view you wish to delete from the View Name list.
Click on <Delete>. A Warning box will appear.
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To confirm the deletion of this view, click on <OK>. To retain the view, click on
<Cancel>.

Copying Advanced Spreadsheet Views



Select the advanced spreadsheet view you wish to delete from the View Name list.
Click on <Copy>. The system will respond with a New Name box.



Enter a name for this view up to 30 characters in length (up to 30 characters, spaces
are NOT allowed, use _ instead).
Click on <OK>. The system will copy the existing ASV including any associated
model to the new view name, and returns control to the View Selection window for
the new ASV.
Make any changes you wish to the copied ASV and click on <Save>.
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Comparing Advanced and Standard Spreadsheet Views

Advanced Spreadsheet Views vs. Standard Spreadsheet Views
Issue
Including different data
elements in the view

Use of columns

Using models
Refreshing data

Subtotals

Zoom feature
Bottom line
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Advanced Spreadsheet View

Standard Spreadsheet View

Allows all the data elements
(funds center, funded program,
decision package, functional area,
grant, fund, and commitment item)
to be included in the view.
Allows the user to use any data
column or any element as a
column.
Allows the use of models.

YES – however, these views
only allow three elements to be
used at any given time.

Allows the user to refresh the data
to include recent changes made in
a budget form without rerunning
the view.
Subtotals can be seen by tabbing
the view by the desired element or
using the “Subtotal” check box in
the Presentation tab.
User can “Zoom” to see details of
a particular cell (audit trail).
Requires more setup than a
standard spreadsheet view, but can
include all the data elements as
well as alter the column structure.

Allows the data columns to be
used, does not allow other
elements as columns.
Allows the use of models.
Allows the user to refresh the
data to include recent changes
made in a budget form without
rerunning the view.
Subtotals can be seen by
tabbing the view by the desired
data element.
User can “Zoom” to see details
of a particular cell (audit trail).
Still requires some setup, but
many standard views have
already been created by the
system administrator.

