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City Budget Office

Budget Monitoring Calendar
Below is the tentative schedule for the current fiscal year. Please note that this schedule is subject to
change. Changes will be noted in CBO Weekly Communications.

Milestone
BMP Manual Update Available
BMP Kickoff Meeting
BRASS Opens to Bureaus

Fall BMP
8/14/2017
8/14/2017
8/21/2017

Spring BMP
n/a
n/a
3/12/2018

OEO
n/a
n/a
5/30/2018

IA Changes Communicated to Service
Providers

9/1/2017

3/16/2018

6/1/2018

Capital Project Scoring Forms due to CBO
Submittal Due to CBO
CBO Technical Checks Complete

9/1/2017
9/11/2017
9/13/2017

n/a
3/26/2018
3/28/2018

n/a
6/4/2018
6/6/2018

CBO Draft Supplemental Budget Analyses to
Bureaus
Final CBO Analysis to Council

9/28/2017
10/10/2017

4/6/2018
4/10/2018

n/a
n/a

CBO Draft Prior Year Performance Report
Analyses to Bureaus
Council Work Session
Ordinance Filed

10/12/2017
10/17/2017
10/17/2017

n/a
4/17/2018
4/17/2018

n/a
n/a
6/12/2018

Budget Kickoff & Prior Year Performance
Report Issued
10/17/2017
n/a
n/a
Public Notice Filed
10/23/2017
4/25/2018
6/13/2018
Council Hearing
11/1/2017
5/2/2018
6/20/2018
Changes Posted to SAP (excluding Grants)
11/3/2017
5/4/2018
6/22/2018
Grants Changes Posted to SAP
11/9/2017
5/7/2018
6/25/2018
* Note that IA changes for the OEO must be communicated to providers prior to the opening of BRASS
**The BMP work session date was updated to October 17th in the Fall and April 17th in the Spring
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Changes to the BMP for FY 2017-18
There are no key changes to the BMP Process this year. This manual is abbreviated to focus on BMP
submittal requirements and instructions; additional resources and background information is available
on the new “BMP Resources” page of the CBO website, here:
http://www.portlandoregon.gov/cbo/71341
In the interest of continual process improvement, CBO always welcomes feedback on the content of this
manual as well as the BMP process as a whole. Please email Jessica Eden, the Budget Monitoring
Process Coordinator, at Jessica.Eden@portlandoregon.gov or 503-823-5738 with any questions or
suggestions for improvement.

Fall BMP Timeline
In response to bureau feedback, for FY 2016-17 we moved the Fall BMP up two weeks. We attempted to
follow the same schedule this year to enable supplemental changes to the budget to take effect in
October; however, scheduling conflicts prevented this. Changes will be available the first week in
November. Please see the calendar dates on page 5 above.
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Fall BMP Instructions
The Fall BMP serves two primary functions: to give City Council and the public a summary of prior year
activity (budget monitoring) and to adjust the current fiscal year budget (supplemental budgeting).
These two functions require distinct information and processing; instructions for each are below.

Fall Budget Monitoring: Prior Year Performance Reporting
Budget monitoring in the fall focuses on Prior Year reporting. There are three different types of
reporting that bureaus are required to provide: updates on budget notes and decision packages; a
reconciliation of actual versus revised budget expenditures and revenues for funds and capital projects;
and data and narrative updates on bureau performance measures. While the type of information
requested of bureaus has not changed, CBO revised the reporting format in FY 2016-17 to be more
relevant and user-friendly.
An example of the new format is available on the CBO website. With the relatively new approach to
reporting on decision package, budget note updates, and bureau performance narrative, detailed
guidance regarding these processes are included below. For remaining reporting components,
instructions to bureaus for submission of year-end financial and performance information is the same as
last year; instructions on submittal requirements are detailed in the Fall BMP section of this manual
below. The FY 2016-17 Prior Year Performance Report will be released on October 17, 20171.

1. Reporting on Decision Packages and Budget Notes
During the Fall BMP, bureaus must provide an update for all budget notes and decision packages that
were included in the prior year adopted budget, and those from the prior year supplemental budget
processes that are flagged for update by CBO. Bureaus submit completed updates in excel format for
decision packages and word format for budget notes.
Decision Packages
CBO will provide you with a comprehensive list of decision packages that require updates in an excel
document, which will also be available on the CBO website. The list will include the decision package
title, description, amount funded, and any authorized positions. Bureaus must populate two columns in
the spreadsheet with information: the “status” and the “update” columns, and should confirm that the
description is accurate. Select the package “status” using the drop down menu provided in the
spreadsheet column (options are ‘Completed’ ‘In progress’, ‘Not started’ or ‘N/A).
For decision packages, in the “update” column, please provide a concise (1-2 paragraph) narrative on
the decision package including the following:

1

FY 2015-16 Prior Year Performance Report: https://www.portlandoregon.gov/cbo/74265
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•
•
•
•

•

Whether new positions have been hired into,
Status and amount of any contracts funded by the package,
Any other spending information,
Any output or outcome information that is available, and specify relation to bureau
performance measures and KPMs (if an impact is not yet detectable but is expected, please
provide the expected impact and timeline), and
Other discussion of the status including delays, changes in scope, etc.

Please include hyperlinks to relevant webpages where appropriate or useful to the public. Please ensure
submissions use language that is clear, concise and objective so that your submission may be posted
directly online.
Budget Notes
For budget notes, please follow the word document template available on the CBO website or contact
your budget analyst for the template. If the status of the budget note is not complete, please provide an
estimated date of completion. If the budget note specifically requires a report during a particular budget
monitoring phase, a link to that report should be included.
Budget note and decision package updates must be completed and submitted to CBO regardless of the
status of the package. Bureaus may choose to provide additional updates to the posts later in the year
as additional progress towards completion is made. To provide an amendment or subsequent update,
bureaus may email a completed updated template to their CBO analyst at any time.

2. Reporting on Fund and Capital Project Actual Spending
Bureaus must submit a reconciliation of prior year revised budget to actual spending for each bureau
fund and overall capital projects. These instructions are the same as they were last year.
Fund Reconciliation
The following instructions are for bureau-specific funds. For multi-bureau funds (such as 100 or 217),
follow the business area reconciliation instructions.
1. Select from the BMP database menu: BRASS>Reports
2. Choose A1 – Fund Reconciliation Report. Click Okay.
3. Select the desired three-digit fund from the Fund drop-down menu.
4. Click okay. The report will populate with data from BRASS. Use the data in the report to craft the
reconciliation narrative to be entered in step 8 below.
5. Select from the BMP database menu: BRASS>Info Edit>Fund.
6. Select the desired three-digit fund from the drop-down menu. Click Okay.
7. Click on the Text tab.
8. Enter reconciliation narrative in the Text 2 field. Click Save when complete. Narratives should
explain any over-expenditure or under-collection of revenue greater than 10% by line item (as
8|Page
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rolled up in the A1 report) and any net over-expenditure or under-collection for the entire fund.
In addition, narratives should include explanations of any other noteworthy variances,
regardless of relative size.
9. Repeat steps 1-4 to generate submittal output.
10. Select from the BMP database menu: File>Print.
11. Click Okay. This output is your BMP submittal. (Note: For PDF output for electronic submission,
press the Printer button and select Adobe PDF prior to clicking Okay.)
Business Area Reconciliation
The below instructions are to reconcile funds that are utilized by multiple bureaus. These instructions
should be used for fund 100 and 217.
1. Select from the BMP database menu: BRASS>Reports
2. Choose A1a – BA Reconciliation Report. Click Okay.
3. Select the desired two-character business area from the Funds Ctr drop-down menu.
4. Select the desired three-digit fund (either 100 or 217) from the Fund drop-down menu. Click
Okay.
5. If resources were budgeted in both the General Fund and the Grants Fund, perform steps 1-4 for
each fund.
6. This report will populate automatically with data from BRASS. Use the data in the report to craft
the reconciliation narrative to be entered in step 10 below.
7.

Select from the BMP database menu: BRASS>Info Edit>Funds Ctr.

8. Select the desired two-character business area from the drop-down menu.
9. Click on the Text tab.
10. Enter reconciliation narrative in the Text 2 field. Click Save when complete. Narratives should
explain any over-expenditure or under-collection of revenue greater than 10% by line item (as
rolled up in the A1a report) and any net over-expenditure or under-collection for the entire
fund. In addition, narratives should include explanations of any other noteworthy variances,
regardless of relative size. Because there is only one field for each business area, if bureaus have
budgeted resources in both the General Fund and the Grants Fund, the narrative should
separately address the two funds.
11. Repeat steps 1-4 to generate submittal output for each fund managed.
12. Select from the BMP database menu: File>Print.
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13. Click Okay. This output is your BMP submittal. (Note: For PDF output for electronic submission,
press the Printer button and select Adobe PDF prior to clicking Okay.)
Note: General Fund discretionary and overhead accounts do not show actuals. These resources are
considered to be the last resources applied – first overhead, then discretionary - to balance to actual
expenditures. While BRASS does not reflect this until the CAFR is finalized, CBO reviews will reflect the
allocation of General Fund resources.
Special Instructions for OMF Bureaus
Because of the text field limitations, General Fund bureaus within OMF should follow the steps for
Business Area Reconciliation above, but with the following changes:
1. In step 3, select the desired four-character business area from the Funds Ctr drop-down menu.
2. Skip steps 7-11. Instead, OMF budget staff should provide a separate document (Microsoft
Word, PDF, etc.) that contains a reconciliation narrative for each SAP division (i.e. four-character
business area) for both General Fund and Grants Fund. Narratives should include the same
information as in step 10 above.
Capital Project Updates
In order to provide Council and the public with a greater understanding of capital project work
(including the lifecycle, status, and type of work accomplished) infrastructure bureaus are required to
provide program-level capital updates during the Fall and Spring BMPs. In the Fall BMP, both prior year
and current year variance reporting is required; during the Spring BMP, only current year variance
explanations are needed. Following are instructions for updating the C2 capital reports. For the Fall
BMP, the C2 report will automatically populate the following information:
• Prior Year Adopted Budget
• Prior Year Revised Budget
• Prior Year End Actuals
• Variance in dollars (Year end actual – Revised Budget)
• Variance in percent (dollar variance / Revised Budget)
In BRASS>Info Edit> Funded Program, bureaus should select the appropriate two-character bureau code
and enter explanations for program variances greater than 10% between the prior year Revised Budget
and prior year actuals into the Text 1 field. This should include a list of the major projects contributing to
the program variance, a status update of the project or group of projects and the amount of the project
variance and any other contextual information that may be helpful to explain the variance. Responses
may be in bullet form and are intended to be high-level. CBO may ask follow-up questions during the
review process.
In both the Fall and the Spring BMP, the C2 report will automatically populate the following information:
• Current Year Adopted Budget
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• Current Year Revised Budget (assumes updates as per the BMP submission)
• Current Year Year-to-date Actuals
• Variance in dollars (Adopted Budget – Revised Budget)
• Variance in percent (dollar variance / Revised Budget)
In BRASS>Info Edit> Funded Program, bureaus should select the appropriate two-character bureau
code and enter explanations for program variances greater than 10% between the current year
Adopted Budget and anticipated Revised Budget (assumed all BMP submissions are approved) into
the Text 2 field.
This should include:
a) a list of the major projects contributing to the program variance,
b) a status update of the project or group of projects and the amount of the project variance, and
c) any other contextual information which may be helpful to explain the variance.
Responses may be in bullet form and are intended to be high-level. Follow-up questions may be asked
during the review process.
All fund and capital project reconciliation reports should be submitted in pdf form with the rest of your
Fall BMP submission.

3. Reporting on Performance Measures
Bureau performance achievements provide City Council with useful context to guide budget decisions.
To assess performance of programs and services in the prior year, bureaus are expected to do the
following:
a. Report accurate and complete prior year actuals data on bureau performance measures,
b. Provide narrative analysis of how prior year measure actuals are tracking to measure strategic
targets for key performance measures,
c. Describe the bureau’s plan to capitalize on strong prior-year performance, or address adverse
results, as applicable.
This information is included in the Performance Measures BRASS report (PM 1 and 2), which is a part of
each bureau’s Fall BMP submittal. When drafting the narrative, bureaus should address the following
questions, and may wish to place emphasis on the bureau’s key performance measures:
Comparison to•
targets and
historical trends
•
•

For key performance measures, how did prior-year actuals
compare to strategic performance targets? Is the bureau
on track to achieve its level of service goals in the
established time frame?
For programmatic measures, how do actuals compare to
year-end targets?
How does performance on the measure trend to past
years?
11 | P a g e

External &
•
Internal Factors
Bureau Actions•
Changes to
•
performance
measures

What changes to bureau internal processes and/or
external factors may have led to particularly strong or
weak performance in bureau programs and services?
What actions might the bureau take to address adverse
trends in performance? To capitalize on strong results?
Has the bureau made any changes to performance
measures between the prior year and current year
Adopted budget? If so, what were these changes and why?

City Budget Office analysts will utilize information submitted by bureaus to review and assess bureau
performance in the Prior-Year Performance Report2. This report highlights the connection between
bureau service delivery and budget expenditures, analyzing important trends and key issues that may
inform upcoming budget decisions. CBO analysts will highlight significant changes to bureau service
delivery, program accomplishments, efforts to bring performance results to meet annual or strategic
targets. Analysts may include recommendations for additional performance measures, or modifications
to current measures.
Please note, bureaus are responsible for the accuracy and completeness of all performance data
entered into BRASS, including annual and strategic targets as appropriate. Bureaus are encouraged to
provide quantitative and qualitative performance data that includes the following.
•

Analysis of Key performance measures that capture the outcomes of the bureau’s core programs
and services.

•

Discussion of programmatic measures (efficiency, effectiveness, and workload measures) that
capture significant bureau accomplishments or changes, negative trends, or changes in program
service delivery.

•

Additional information supporting significant program achievements, changes, or challenges,
including internally tracked measures or outputs.
Bureaus may be contacted by their CBO analysts to discuss the details of bureau submissions on
the questions noted above.

To enter the prior year actuals data and narrative:
1. Open BRASS budget production database (not the BMP database) for the next budget cycle
2. From the BRASS menu, Select Performance Measures>Values.
3. From the Controlling Org dropdown menu, select the appropriate business area and click Okay.
4. In the PY1 column, enter data for the prior year actuals. [Note: While entering ‘999999’
generates an ‘NA’ in Patternstream for budget development, it generates a ‘0’ in the BRASS

2

FY 2015-16 Prior Year Performance Report: https://www.portlandoregon.gov/cbo/74265
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reports. If a bureau is unable to provide data on a measure for the prior year, this should be
explained in the narrative.]
5. From the BRASS menu, select Info Edit>Funds Ctr.
6. From the Funds Ctr dropdown menu, select the appropriate two-character business area and
click Okay.
7. Click on the Text tab.
8. In the Text 2 field, enter narrative describing how prior year measure actuals compare to
measure strategic targets for each key performance measure. For programmatic measures with
budgetary significance that lack strategic targets, compare achievement to annual targets.
Highlight notable bureau achievements and/or corrective action the bureau will take to address
adverse trends. Discuss changes to measures that the bureau is tracking (from PY to CY). Include
information that will assist Council in understanding program results.
9. Click Save.
10. From the BRASS menu, select Reports.
11. Select the PM1 Performance Measures report. Click Okay.
12. From the Funds Ctr drop down menu, select the appropriate two-character business area. Click
Okay.
13. From the File menu, select Print.
14. Click Okay. This output is your BMP submittal. (Note: For PDF output for electronic submission,
press the Printer button and select Adobe PDF prior to clicking Okay.)
To add, change, or archive a bureau performance measure, fill out this form and contact your CBO
analyst. The Performance Manual offers additional guidance. Contact your CBO analyst or Shannon
Carney, CBO performance management analyst (3x6807) with questions about performance updates or
narrative submission.

Fall Supplemental Budgeting – General Guidelines
Budget adjustments in the Fall BMP are primarily related to encumbrance carryovers or the addressing
of new, urgent and unforeseen needs. Unspent grant appropriations from the prior year that are
expected to be spent in the current year are budgeted during the Fall BMP with approval from the
Grants Office in OMF. Any requested changes to the budget must be completed through the use of
forms in the BRASS BMP database. Instructions for entry are below.
Per City Financial Management Policy, 50% of the City’s General Fund excess balance should be used for
infrastructure maintenance (FIN 2.03). The remaining 50% of any excess balance is added to contingency
(FIN 2.04). Major infrastructure maintenance projects requesting to be considered for funding in the Fall
BMP need to be included in the citywide project ranking process which is being conducted in
coordination with the Fall BMP.
13 | P a g e

Discretionary Underspending
Bureau and Citywide discretionary General Fund underspending in the prior year is a large factor in
determining ending balance and the availability of beginning balance to fund expenses in the current
year.
Bureau discretionary under- or overspending in the prior year is calculated by subtracting nondiscretionary revenue and General Fund overhead from total expenses and comparing the result with
the discretionary allocation.
Example: If a bureau has spent $1 million in the General Fund, collected $25,000 in revenue, and receives
$100,000 in General Fund overhead, the bureau has spent $875,000 of General Fund discretionary. If the
bureau’s discretionary allocation was $925,000, the maximum carryover the bureau may request is
$50,000. (Note: If non-discretionary revenue is requested for carryover, that amount will be backed out
of the calculation of discretionary spending – i.e., discretionary spending in the prior year increases, thus
decreasing the amount of encumbrance carryover that can be requested.)

Encumbrance Carryover
Once the prior fiscal year is closed, bureaus can determine what encumbered budget was unspent.
Bureaus may request to re-budget funding for those encumbrances in the Fall BMP, with exceptions.
For General Fund resources, CBO analyzes requests and, to the degree that the Citywide General Fund
ending fund balance target was achieved in the prior year, recommends funding for those encumbrance
carryovers that are true one-time costs up to a maximum equal to bureau discretionary General Fund
underspending (as discussed in the section above) or total materials and services and capital outlay
underspending – whichever is less.
CBO typically does not recommend encumbrance carryovers for the following:
•

Annual materials and services allocations – particularly flexible professional services contracts –
and other annual contracts funded in the current year

•

Contracts that have expired with open purchase orders, or purchase orders that remain open
but for which the bureau does not intend to have goods or services delivered

Occasionally, bureaus will request a service of another bureau through an interagency agreement that
will result in a purchase order encumbrance that is carried over on the provider side. In these instances,
General Fund bureaus may request encumbrance carryover for those costs even though the
encumbrance does not appear to be in the General Fund.
Prior to FY 2016-17, CBO provided bureaus with a worksheet to identify requested encumbrance
carryovers from open purchase orders (POs). Continuing in FY 2017-18, CBO requests that bureaus
provide this information in concert with PO accrual information that was provided to accounting as part
of year end close.
Bureaus should add a column titled “Encumbrance Carryover Request” to the accrual worksheet already
submitted to accounting, and populate that column with the amount of remaining open PO funds that
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the bureau wishes to carryover. This exercise only needs to be completed for General Fund open POs.
This format will enable bureaus and CBO to easily determine accrual and carryover requests for each
open General Fund PO. The sum of these encumbrance carryover requests plus advance recovery
funding should be equal to the amount requested in BRASS.
Bureau’s General Fund encumbrance carryover requests (including advance recovery funding) will be
limited to General Fund underspending in the prior year.
In the event that the General Fund ends the prior fiscal year with a balance lower than what is necessary
to balance the five-year forecast, carryover funding may not be available for all encumbrances. For nonGeneral Fund resources, encumbrance carryover is mostly at the discretion of the bureau based on
ending and beginning fund balance, available grant allocations, etc.

General Fund Program Carryover
General Fund Program Carryover that is approved by City Council is rebudgeted in the Approved Budget
in May.
No program carryover requests for General Fund discretionary will be recommended by CBO in the Fall
BMP. All program carryover must be budgeted in the Approved Budget; otherwise, the request must be
entered as a “New Request” in the Fall BMP.

General Fund Non-Discretionary Carryover
Some bureaus collect revenue in the General Fund. In the case that individual programs earn revenues
greater than program expenses, bureaus can request carryover of the excess. Comprehensive Financial
Management Policy 2.06 states:
“Bureaus shall retain all excess bureau-generated revenue. Revenues collected in excess of program
expenditures shall be available to the bureau for appropriation through the budget monitoring process.
Additional appropriations shall be used for activities that support the function or program generating the
additional fees. Bureau-generated revenue shall be defined as licenses and permits, fines, fees,
intergovernmental, and specific program revenues (miscellaneous sales). They shall exclude all
interagency and General Fund discretionary or overhead resources.”
Any request for revenue carryover should include a reference to the level of the budget at which the
analysis was done, the budget structures that were identified as having revenues greater than fullyloaded expenses, and detailed form entry to allocate the carried over revenues to the same program.
Any amount carried over as per this policy will reduce the amount of calculated discretionary
underspending by the bureau. In the event that insufficient underspending exists bureau-wide, revenue
carryover will not be approved.

Advance Recovery Funding
Bureaus with advances made in prior years, for which the service has not yet been received, must
rebudget or otherwise plan for the “recovery” of those advances. The “recovery” occurs when the good
or service is delivered and the expense hits the general ledger.
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Outstanding advances made in the General Fund should be requested by bureaus in the same way and
with the same restrictions as encumbrance carryovers. That is, advance recovery funding plus other
encumbrance carryover may not exceed the amount of discretionary underspending or non-personnelrelated underspending, whichever is less.3
Outstanding advances made in the other funds should be budgeted either in bureau expenses or in
bureau contingency and funded out of additional beginning fund balance. See page 22 for additional
instructions on advances.

General Fund Major Maintenance Requests from Excess Balance
All City bureaus may request funding to support major maintenance and replacement projects in years
in which excess balance is available in the General Fund, as directed by City Financial Management
Policy. CBO coordinates a working group consisting of bureau asset managers that has developed a
prioritization mechanism to assist City Council in allocating this set-aside during the fall BMP and budget
development. This tool is used to score and rank projects based on the likelihood and consequence of
asset failure.
The FY 2017-18 Fall BMP Project Ranking Process will be built off the process used during FY 2017-18
budget development. Project ranking will begin with the existing ranked list created through the FY
2017-18 budget development process, then incorporating any new information from bureaus utilizing
the project scoring tool. If a bureau would like to request one-time General Fund resources in the Fall
BMP for a new project, or would like to revise a project currently on the ranked list, the bureau must use
the project scoring tool to evaluate and score the desired major maintenance and asset replacement
project.
Detailed instructions and examples illustrating how to complete the Project Scoring Worksheet and
Request Form for the Fall BMP are available in the Capital Set Aside Instructions manual available online.
To be included for funding consideration in the fall BMP, new or revised project forms must be sent to
Claudio Campuzano (Claudio.campuzano@portlandoregon.gov) by September 1st 2017. Bureaus must
also include a decision package request for the project in their BMP submittals to CBO on September
11th.
At the time of this manual’s release, the amount (if any) of the excess ending balance is not known. Last
year, there were $59.25 million in capital project funds requested from the Capital Set-Aside account. Of
those requests, $4.3 million was awarded for capital set-aside projects during the Fall BMP. Bureaus
should be cognizant of the number of high-ranking projects on the existing ranked list when prioritizing
bureau staff time during the BMP process.

3

A one-time exception was made for bureaus that carried advance balances into FY 2011-12. Those bureaus were
allowed to exceed their underspending limitation by an amount equal the balance carried into FY 2011-12. This
exception was made because, prior to FY 2011-12, advance recovery funding was held in a set-aside and not in the
bureau budget
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Reductions for General Fund Overspending
If a bureau overspent its discretionary allocation in the prior year, an equivalent reduction should be
made to the bureau’s budget in the Fall BMP. Additionally, no encumbrance carryover shall be granted.
See the section above for the methodology for calculating under- or overspending.

Grant Carryover
Unspent grant appropriations from the prior year that are expected to be spent in the current year are
budgeted during the Fall BMP with approval from the Grants Office in OMF.

Beginning Fund Balance Adjustment
Non-General Fund bureaus may request increases to a fund’s beginning balance when the additional
balance is needed for planned expenditures, carryover or otherwise, or to increase contingency to
reflect unplanned-for, additional balance.

General Fund Contingency Requests
During the Fall BMP, bureaus may request General Fund contingency. Often, during the year, City
Council will act by ordinance or resolution to commit contingency without appropriating it. If City
Council has taken such an action prior to the Fall BMP, the request for appropriation should be included
in the BMP request.

Other New Requests
If, after the current year budget is adopted, bureaus become aware of additional resources in their
funds, they may request additional appropriation during the Fall BMP.

Position Changes
Typically, BMPs will not be used by General Fund bureaus to make position changes since permanent
positions require ongoing funding, a resource that is typically not available during the fiscal year.
However, ongoing, regular positions can be created by reallocating existing discretionary resources.
Limited term positions do not require Council approval and therefore can be approved outside of the
BMP process.
If, in order to create a limited term position, General Fund bureaus need to move funding from another
major object or require General Fund contingency, requests for both the position and the shift in
resources can and should be made in the Fall BMP.
Non-General Fund bureaus may request to create permanent positions in the Fall BMP if ongoing
resources are available.

Interfund Loan Repayment
According to local budget law, City funds may not end the fiscal year with a negative fund balance.
Because of the modified accrual basis of accounting, grant revenue is only booked when it is received,
not when it is earned. Any revenue that is deferred to the next fiscal year generates a negative balance
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in the grants fund. In order to alleviate this, loans must be made from operating funds of the bureaus
responsible for the deferred revenue.
Additionally, Generally Accepted Accounting Principles (GAAP) require that funds not end the year with
a negative cash balance. Such a situation would also necessitate an interfund loan.
The loans necessary to address these issues are budgeted in the Over-Expenditure Ordinance, and, to
the degree possible given the 10% limit on appropriation changes between the Approved and Adopted
Budgets, the repayments are budgeted in the Adopted Budget. Once the final amounts of the loans have
been determined as part of the year-end close process, affected bureaus that did not budget the
repayment in the Adopted should budget repayment in the Fall BMP.
This issue only affects a few bureaus. Those bureaus will be contacted by the assigned CBO analyst to
ensure the appropriate request is made.

Other Changes
Other technical changes, besides those described above, may be requested during the Fall BMP.

Current Appropriation Level (CAL) Adjustments
Occasionally bureaus will request changes to their out-year CAL targets. These requests are not entered
into BRASS during the BMP processes and therefore should be requested through a separate
communication with their CBO analyst.

Fall Supplemental Budgeting – Instructions for Entry into BRASS
Budget adjustments are requested in BRASS by 1) using Info Edit to create requests and attach narrative
and other information to these requests, 2) using request forms to enter the budget data, and 3) using a
report to summarize submittal. Below are detailed instructions for entry; CBO has also created
screencast trainings available online to demonstrate these instructions.

Info Edit
The first step in creating a request is to provide narrative for the request in BRASS Info Edit using a
Request Number. This step establishes the request narrative and codes the request by Type and
Resource. Use the following guidelines for creating request numbers:
•

Each request number has only one Type and only one Resource associated with it.

•

If necessary, a request should be broken up into several request numbers in order to properly
code the Type and Resource.

•

Additionally, a separate request number should be used for each distinct, unrelated item.

•

The above bullet notwithstanding, all technical adjustments with the same resource coding
should be grouped with a single request number. The narrative should discuss all adjustments
briefly.
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Creating Info Edit for a Request Number
1. Select from the BMP database menu: BRASS>Info Edit>Request #.
2. From the drop-down menu, select the next available request number for the desired business
area. The next available request number should be titled ‘Request Title’. Note that request
numbers are sequential through the entire fiscal year for all BMPs. Request numbers and titles
from prior BMPs will be visible in the drop-down menu. Do not reuse existing request numbers.
If there are no available request numbers, contact your CBO analyst to direct the BRASS
Administrator to create new numbers.
3. Click Okay.
4. In the Name field, enter the request title to appear in the submittal to City Council. This title
should concisely describe the request.
5. In the Type and Resource fields, make the appropriate selections from the drop-down menus.
See below for guidelines on Type and Resource selections.
6. The default selection for the Report field includes the request in all reports. Bureaus should not
change this setting without consulting their CBO analyst. Excluded requests will not show up in
reports, but will show up in spreadsheet views and in budget adjustments.
7. Click on the Text tab.
8. In the Text 1 field, enter a detailed description of the request. For technical adjustments, this
includes a clear discussion of all material changes. For new requests, please address the
following questions to minimize the amount of follow-up questions from CBO:
•

What are the expected results/outcomes of the DP? Please refer to impact on
performance measures and KPMs as appropriate.

•

What are the assumptions and estimates used in describing the expected
results/outcomes?

•

What are the consequences if funding is not approved?

•

Is this effort/project mandated by any rules/regulations: local, state, federal?

•

Does the bureau have a system in place to track and report on the expected results?

•

Is the full amount needed for the requested period? If not, how much is needed in this
fiscal year?

•

Can this project/program be postponed to next fiscal year? Explain.

•

Can this project/program be done in phases? Explain.

•

For General Fund requests: Has the bureau explored alternative funding options:
program revenues, grants, etc.…to fund this project/program? Explain the process.

•

If this is a new project/program, has this been implemented by any local or regional
agencies? If so, has it been a successful experience?

•

Does this request leverage other funding sources?
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9. Click Save.
BMP Request Type and Resource Guidelines
Technical Adjustments: The ‘Technical Adjustments’ request type usually includes transactions
requesting changes to approved activities that require adjustments due to technical budgeting or
accounting requirements. These transactions do not increase the total appropriation of the business
area (for General Fund bureaus) or fund (for non-General Fund bureaus). Examples of these
housekeeping changes may include transfers between materials and services and capital outlay due to a
change in the nature of capital equipment required, changes in procurement of an item from a City
bureau (internal materials and services) to an outside vendor (external materials and services), or the
breaking out of an existing budget to a greater level of detail. Transfers of General Fund between
bureaus should also be considered a technical adjustment, provided that the net effect is zero. Technical
adjustments do not include program expansions, new positions, cost overruns, or any action which
would require a draw from contingency from any fund. For most technical adjustments, the resource
should be ‘Internal Transfer’. For General Fund transfers between bureaus, the resource should be
General Fund on both sides of the transaction.
Carryover: The Carryover request type is used by General Fund bureaus to reduce appropriation in the
Spring BMP so that those funds can be included in the Approved Budget of the following year. NonGeneral Fund bureaus also may request carryover in the Spring BMP and rebudget it in the following
year as part of the budget development process. For General Fund bureaus, the resource should be
‘General Fund’. For non-General Fund bureaus, the resource should be ‘New Revenue’ or ‘Bureau
Contingency’. The ‘Grant’ resource may also be used for all grant-related carryover.
Encumbrance Carryover: The ‘Encumbrance Carryover’ request type should only be used during the Fall
BMP for encumbrances and funding for outstanding advances. CBO analysts will provide bureaus with a
General Fund Encumbrance Carryover Detail Worksheet that shows all encumbrances that were carried
forward into the new fiscal year in SAP. Encumbrances are automatically calculated in SAP and can be
viewed in SAP FM reports by viewing AP 1 budget-to-actuals and drilling down into the PO column. In
that column, lines with Amount Type 350 are those that were brought in from the prior fiscal year.
Bureaus should review those items that were carried over and determine which encumbrances should
be closed, which may have already been relieved in the prior fiscal year through an accrual journal entry,
which should be funded with ongoing base budget in the current fiscal year, and which should be
requested as encumbrance carryover. For General Fund bureaus, the resource should be ‘General Fund’.
For non-General Fund bureaus, the resource should be ‘New Revenue’ or ‘Contingency’.
Most General Fund bureau encumbrances will be backed by prior year resources that fall to fund
balance. However, some encumbrances are tied to interagency or contract revenue that will be received
in the current year. These should be coded as ‘New Revenue’.
Requests to offset advance recoveries should be made as encumbrance carryover requests. Restrictions
on the total encumbrance carryover funding available for General Fund bureaus is discussed on page 15.
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New Request: The ‘New Request’ type is used for any other request that increases the level of
appropriation at the fund or business area level or that shifts funding to reflect a change in
programmatic priorities. Bureaus may request funding from General Fund contingency for new items
not included in the budget. To make such a request, use the Info Edit form to describe the request,
including what it will accomplish, who will benefit, and why this item was not included in the budget.
Explain why this request is necessary, and the consequences of any decision not to fund this request. A
request for General Fund contingency should be coded with ‘General Fund’ as the resource. Other
resource types that can be used for ‘New Requests’ include ‘New Revenues’, ‘Bureau Contingency’, and
‘Grants’.
Reduction: This type is used for any reduction in appropriation. The resource type should be ‘General
Fund’ for General Fund reductions or ‘New Revenue’ in all other funds.
Comp Set-Aside: If, during the year, General Fund bureaus project that vacancy savings will not be
sufficient to cover costs related to collective bargaining, a request for Comp Set-Aside may be made.
Such requests should use ‘General Fund’ as the resource. For non-General Fund bureaus, Comp SetAside request types should be coded with the ‘Bureau Contingency’ resource type.
Capital Project Set-Aside: In years in which excess balance is available in the General Fund for major
maintenance and infrastructure replacement projects as directed by City Financial Management Policy,
bureaus may use this request type to make requests to utilize the infrastructure project set-aside
portion.
In FY 2014-15, a ranking process was established for capital projects seeking funding through the capital
set-aside. Projects are submitted to CBO outside of the regular BMP process. Bureaus self-score the
projects across a number of criteria. The project scoring is validated and the projects ranked by a
committee of City asset managers. Projects will be added to the existing list of projects that were
requested but not funded in the FY 2017-18 budget process.
Additionally, it is important that project requests include the total net operations and maintenance
costs, including any projected impacts on the General Fund and confidence level of the estimate.
Funded Fall BMP projects that require additional operations and maintenance funding will need to
request the ongoing General Fund during the annual budget process. See Budget Manual or financial
procedure 2.03.02 for more detailed instructions if applicable.

Encumbrance Carryover Detail Worksheet
In the past, CBO provided bureaus with a worksheet to identify requested encumbrance carryovers from
open purchase orders (POs). Beginning in FY 2017-18, CBO requests that bureaus provide this
information in concert with PO accrual information provided to accounting as part of year end close.
Bureaus should add a column titled “Encumbrance Carryover Request” to the accrual worksheet already
submitted to accounting, and populate that column with the amount of remaining open PO funds that
the bureau wishes to carryover. This exercise only needs to be completed for General Fund open POs.
This format will enable bureaus and CBO to easily determine accrual and carryover requests for each
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open General Fund PO. The sum of these encumbrance carryover requests plus advance recovery
funding should be equal to the amount requested in BRASS.
As noted in the Fall BMP section earlier, bureaus’ General Fund encumbrance carryover requests
(including advance recovery funding) will be limited to General Fund underspending in the prior year.

Advance Analysis and Requests
Advances can be very challenging to monitor because of the way the SAP system is configured. While
the cash has been disbursed, no expense hits the general ledger until goods or services have been
received (i.e. the advance is ‘recovered’). Therefore, if an advance is outstanding at the end of the fiscal
year, budget will need to be requested in the Fall BMP to fund those expenses when they occur (i.e. the
‘recovery’ of the advance).
What makes this analysis particularly complicated is that the FM module of SAP (i.e. the budget-toactuals module) shows the advance as an expense when the cash goes out – not when the goods are
received. Conversely FM does NOT show the goods receipt as an expense. The result is that, in the event
that advances are not made and recovered in the same fiscal year, FM and the CAFR (i.e. FI) will not
match. The CAFR is correct in these cases. Years in which bureaus make net advances will result in a
CAFR actual lower than the FM figure. Years in which bureaus make net recoveries will result in a CAFR
actual higher than the FM figure.
Advances in the General Fund, as noted earlier, are treated as encumbrances for carryover purposes, so,
bureaus should analyze what their outstanding balance is and request it in the Fall BMP (assuming the
bureau had sufficient General Fund underspending in the prior year to cover all advances and
encumbrances, as discussed earlier). Bureaus with advances will need to create a decision package with
the encumbrance carryover type to carry forward the advances to the current year.
The easiest way to determine balance is to use the FAGLB03 report with the ADVANCE_BAL variant. The
sum of the ‘Balance’ column is typically the adjustment that needs to be made to FM actuals to arrive at
the CAFR figure. The ‘Cumulative balance’ column shows the advance balance carried into the year (at
the top) and (at the bottom) the total balance to date - or at the end of the year for closed years.
Bureaus should be cautioned, however, that this report can be inaccurate at certain points during the
year if recoveries were accrued at the end of the previous fiscal year. Please contact Accounting in OMF
if you have any concerns about the balances you are seeing.

Form Entry
The BRASS BMP forms 1-4 are used to enter adjustment data once request numbers have been created
and Info Edit entry is complete.
Each bureau should use one form for each BMP. All request data can – and, in most cases, should - be
entered in a single form. Occasionally, bureaus might want to create multiple forms in order to allow
multiple users to enter data simultaneously. Bureaus should not use a separate form for each fund or for
each request.
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Below is a step by step guide to entering data into BMP forms:
1. Select from the BMP database menu: BRASS>Budget Forms.
2. Click on the form that corresponds to the current BMP (Fall, Spring, or OEO). Click Okay.
3. Select the desired two-character business area from the Funds Ctr drop-down menu.
4. If returning to an existing form, select that form from the Serial Number drop-down menu, click
Okay, then skip to step 8. If this is the first time entering data for the current BMP, select (New)
from the Serial Number drop-down menu.
5. Enter a form title in the Description field. This title should begin with the bureau name or
acronym and the cycle. If bureaus use multiple forms for multiple users, the name of the user
should be on the form name. E.g. “PHB Fall BMP John Doe”.
6. Select ‘A’ from the Stage drop-down menu.
7. Click Okay.
8. Click Insert to insert lines. Lines are inserted below the currently selected line.
9. For each line, select the desired request number from the Request # drop-down menu and enter
all budget adjustment information. Multiple request numbers can and should be used in a single
form.
10. For all lines that affect grants funds (217, 218, 219), enter the sponsored program in the Justify
column before any other text. Please review the current sponsored program(s), and budget only
to fund centers, functional areas, and funded programs associated with existing sponsored
programs. Please discuss any grants changes with your Grants analyst prior to submission.
11. In addition to sponsored program information, enter any other information in the Justify column
that will assist in understanding the context of the line. Information might include what program
the adjustment affects, where any expense or revenue changes are offset, and who directed the
change and when.
12. When form is complete and balanced, click Save.
Tip: Packages that only move revenue will not show in the A9 BMP Request report. In order to get these
to show, enter two lines of expense data that net to ‘0’.

Form Entry – Position Changes
If position changes are included in the BMP, bureaus should utilize the Position tab in the BMP form.
Information added and saved in this tab will populate the General tab of the form with appropriate
default position costs, depending on the class, step, category, etc. Below is a step by step guide to
entering data into BMP Position tab:
1. Open the form as per steps 1-7 above.
2. Click on the Position tab.
3. Click Insert to insert as many lines as needed. Lines are inserted below the currently selected
line.
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4. For each line, select the desired request number from the Request # drop-down menu and enter
all budget adjustment information. Multiple request numbers can, and should, be used in a
single form.
5. In addition to the standard budget information, enter the desired Class and Category. These
fields must be filled in. Note that the Category field indicates not only the bargaining unit, but
also whether the position is Full Time, Part Time, or Limited Term. For example, there are three
selections for DCTU – DT, DTPT, and DTLT. Please make sure to select the correct one.
6. The Step field may be left blank.
7. The Start and End fields require a two- digit month and a four digit year, separated by a slash.
The End field may be left blank if the position is Full Time or Part Time.
8. The FTE field is a percentage number, so one full-time position would be 100. A half time part
time position would be 50.
9. The Count field should identify the number of positions affected by the change.
10. Leave the Salary field blank.
11. Click the Calc button to calculate the annual cost.
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Spring BMP Instructions
The primary purposes of the Spring BMP are to project spending for the remainder of the fiscal year and
to make necessary adjustments to bureau budgets. At this point in the fiscal year, bureaus and CBO
should be able to project spending and revenues with a reasonable degree of accuracy.
The Spring BMP also provides City Council and the public with an update on current year decision
packages and BMP changes, performance measures, budget notes, and capital spending.
Position changes are allowed during the Spring BMP. Any changes to bureau staffing should be
incorporated into development of the budget for the next fiscal year. It is critical that bureaus submit all
necessary paperwork immediately after the supplemental budget is passed so that any new positions or
other changes can be implemented in the Approved Budget for the following year.

Spring Budget Monitoring: Current Year Reporting and Projections
1. Reporting on Budget Notes and Decision Packages
During the Spring BMP, bureaus must provide an update for all budget notes and decision packages that
were included in the current year adopted budget, and those from the current year supplemental
budget processes that are flagged for update by CBO.
CBO will provide you with a comprehensive list of decision packages that require updates in an excel
document, which will also be available on the CBO website. The list will include the decision package
title, description, amount funded, and any authorized positions. Bureaus must populate two columns in
the spreadsheet with information: the “status” and the “update” columns, and should confirm that the
description is accurate. Select the package “status” using the drop down menu provided in the
spreadsheet column (options are ‘Completed’ ‘In progress’, ‘Not started’ or ‘N/A).
For decision packages, in the “update” column, please provide a concise (1-2 paragraph) narrative on
the decision package including the following:
•
•
•
•

•

Whether new positions have been hired into,
Status and amount of any contracts funded by the package,
Any other spending information,
Any output or outcome information that is available, and specify relation to bureau
performance measures and KPMs (if an impact is not yet detectable but is expected, please
provide the expected impact and timeline), and
Other discussion of the status including delays, changes in scope, etc.
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Please include hyperlinks to relevant webpages where appropriate or useful to the public. Please ensure
submissions use language that is clear, concise and objective so that your submission may be posted
directly online.
Note that in the Spring, the excel sheet will also contain prior year decision packages that you already
updated during the Fall BMP. If you have any additional information to provide on these packages, feel
free to update them. All updates will be included online.
For budget notes, please follow the word document template available on the CBO website or contact
your budget analyst for the template. If the status of the budget note is not complete, please provide an
estimated date of completion. If the budget note specifically requires a report during a particular budget
monitoring phase, a link to that report should be included.
Budget note and decision package updates must be completed and submitted to CBO regardless of the
status of the package. Bureaus may choose to provide additional updates to the posts later in the year
as additional progress towards completion is made. To provide an amendment or subsequent update,
bureaus may email a completed updated template to their CBO analyst at any time.
**Please ensure that bureau submissions for budget note and DP updates are in word format and
provide clear, concise and objective information so that they may be directly uploaded to the CBO
website.**

2. Reporting on Performance Measures
During the Spring BMP, bureaus are required to submit updates to their current year estimates to their
performance measures. This additional CY estimate, beyond the Requested budget submission entry,
provides more timely information on measures available on a sub-annual basis. Technical instructions
for current year-end estimate reporting is as follows:
In the FY 2018-19 Production database, use BRASS>Performance Measures>Values to enter
performance measure data for:
•

CY _REVBUD: Current year-end estimates

3. Projecting Current Year Fund Spending
In the Spring BMP, bureaus are required to submit current year projections of a) all funds managed by
the bureau and b) the General Fund (100) and the Grants Fund (217) for their bureau business area.
After submittal of the BMP, CBO will review bureau projections and attempt to resolve any
discrepancies between bureau and CBO projections. Methodologies and assumptions can vary
considerably between projections, occasionally making consensus difficult. Should consensus not be
possible, CBO analyses will include CBO projections, and identify and explain the discrepancies in the
review narrative.
Projection submittals are generated using BRASS reports with input from bureaus. Bureaus enter the
projection data into the appropriate BRASS form. Text is then added to the projection using the
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appropriate BRASS Info Edit – either for the business area or fund. Finally, the fund and business area
BRASS reports are used to generate the submittal output.
The technical steps for the submittal of each are described below. These instructions do not include
direction on how to develop projections. Bureau budget staff must develop their own methodology for
projecting expenses and revenues. CBO analysts can assist in developing a methodology, if requested.
Form Entry
1. Select from the BMP database menu: BRASS>Budget Forms.
2. Choose 5. Year-end Projection. Click Okay.
3. Select the desired three-digit fund from the Fund drop-down menu.
4. Select the desired two-character business area from the Funds Ctr drop-down menu.
5. Check the Serial Number drop-down menu. If the fund/business area combination you would like to
project already has an existing serial number (i.e. form), select it from the Serial Number drop-down
menu, click Okay, and skip to step 7. Do not create a new serial number. The data entered into a new
form will be additive to any existing forms.
6. If the fund/business area combination you would like to project does not have an existing serial number:
a) select any functional area used by the bureau from the FuncArea drop-down menu, select (New) from
the Serial Number drop-down menu, enter a description in the appropriate field (e.g. ‘Trans Op
Projection’ or ‘Fund 200 Projection’), and select A from the Stage drop-down menu. Press Okay.
7. If you created a new serial number, the form should be blank. If you are using an existing serial number,
it may contain prior BMP data.
8. To input data within existing forms, change the amount in the Projection column to reflect the new
projection. Enter the projected year-end totals for each line. New lines with additions or subtractions
are not necessary. To begin a new form, press the Insert button to create as many lines as needed in the
form. Use the drop-down menus to populate the Funds Ctr, Fund, FuncArea, and CommItem with the
appropriate master data. Click Save when complete.
9. Projection data will be displayed in reports at the major object level by business area by fund. Therefore,
CBO recommends that bureaus develop projections offline and enter them into the form using a single
fund/fund center/functional area/commitment item string for each major object.
Example: The Portland Housing Bureau projects spending a total of $227,727 in the General Fund on
Personal Services (including overtime, benefits, etc.). Rather than allocate this projection out to all the
various budget structures, the entry could be: Funds Ctr HCMG000001, Fund 100000, FuncArea
CDEH000000, CommItem 511100, Projection $227,727.
10. The above notwithstanding, bureaus may, if they desire greater visibility in the system, enter projections
with whatever level of master data detail they feel is appropriate. However, the A2 projection reports
will only show projections at the major object level.
11. Repeat steps 1-10 for each unique fund/business area combination for which the bureau is responsible.
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Fund Projection
1. Select from the BMP database menu: BRASS>Info Edit>Fund.
2. Select the desired three-digit fund from the drop-down menu.
3. Click on the Text tab.
4. Enter reconciliation narrative in the Text 1 field. Click Save when complete. Narratives should explain
any over-expenditure or under-collection of revenue greater than 10% by major object and any net
over-expenditure or under-collection for the entire fund. In addition, narratives should include
explanations of any other noteworthy variances, regardless of relative size.
5. Select from the BMP database menu: BRASS>Reports.
6. Choose A2- Fund Projection Report. Click Okay. Revised budget data reflects any adjustments made in
the current BMP. Projection data compiles all form data that affects the selected fund.
7. Check output to ensure that a) budget and actual figures match bureau offline projections and b)
narratives tie to reported figures.
8. Repeat steps 1-8 for each fund in the business area other than the General Fund (100) and the Grants
Fund (217).
Business Area Projection
1. Select from the BMP database menu: BRASS>Info Edit>Funds Ctr.
2. Select the desired two-character business area from the drop-down menu.
3. Click on the Text tab.
4. Enter projection narrative in the Text 1 field for both the General Fund and the Grants Fund, if
applicable. If the narrative relates to both funds, there should be a clear break in the text field. Click
Save when complete. Narratives should explain any over-expenditure or under-collection of revenue
greater than 10% by major object and any net over-expenditure or under-collection for the entire
bureau. In addition, narratives should include explanations of any other noteworthy variances,
regardless of relative size.
5. Select from the BMP database menu: BRASS>Reports.
6. Choose A3- BA Projection Report.
7. Select the desired two-character business area from the Funds Ctr drop-down menu.
8. Select 100 from the Fund drop-down menu.
9. Click Okay. Budget data reflects any adjustments made in the current BMP. Projection data compiles all
form data that affects the selected fund and business area combination.
10. Check output to ensure that a) budget and actual figures match bureau offline projections and b)
narrative from the General Fund section of the text field ties to reported figures.
11. Repeat steps 5-10, substituting fund 217 in step 8 and checking to narrative from Grants against the
figures in step 10.
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Special Instructions for OMF Bureaus
Because of the text field limitations, General Fund bureaus within OMF should follow the steps for
Business Area Projection above, but with the following changes:
1. Skip steps 1-4. Instead, OMF budget staff should provide a separate document (Microsoft Word, PDF,
etc.) that contains a reconciliation narrative for each SAP division (i.e. four-character business area) for
both General Fund and Grants Fund. Narratives should include the same information as in step 4 above.
2. In step 7, select the desired four-character business area from the Funds Ctr drop-down menu.

Spring Supplemental Budgeting – General Guidelines
General Fund Compensation Set-Aside Requests
When developing bureau budgets, CBO does not project cost of living adjustments (COLA) or health
benefits increases in budgeted salaries and benefits, except in the case of Council Offices.4 Non-General
Fund bureaus and bureaus with a significant non-discretionary General Fund budget are expected to set
aside appropriate amounts in their own budgets.
For COLA and health increases associated with staff supported by discretionary General Fund, CBO sets
aside an amount in the General Fund referred to as the Compensation Set-Aside. Barring unforeseen
fiscal issues, this amount is available to General Fund bureaus during the Spring BMP in the event that it
is needed in order to avoid over-expenditure. However, CBO expects that most bureaus will not be fully
staffed throughout the year and that COLA and increased health costs for General Fund bureaus can be
funded with salary savings.
CBO will make recommendations on Compensation Set-Aside requests based on the requesting bureau’s
cumulative budget adjustments throughout the year. Compensation Set-Aside allocations for each
bureau may be reduced by the amount of budget transfers out of Personnel Services.

General Fund Program Carryover
During the Spring BMP, General Fund bureaus may request that current year appropriation for one-time
projects be carried over into the next fiscal year. Approved requests will be removed from the bureau’s
current year budget and added, through the Approved Budget, to the bureau’s budget in the next fiscal
year.
After the BMP is heard by Council, bureaus can enter authorized carryover in the budget production
database when it opens for the Approved Budget.
As with all one-time funding, program carryover that is unspent on the program, for which it was
allocated, will be retained by or returned to the General Fund.

4

Beginning in the FY 2014-15 Adopted Budget, Council Offices have compensation set-aside built into their CAL
targets.
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Other Program Carryover
Non-General Fund bureaus may request that current year appropriation be reduced in order to make
the appropriation available to budget in the new fiscal year as part of the budget process.

Debt Service Adjustments
During the Spring BMP, bureaus must make adjustments to true up cash transfers to debt service funds
from operating funds to reflect any changes or modifications to their debt service requirements that
occurred, or are expected to occur, during the fiscal year.

Major Object Adjustments
With reasonably accurate estimates of year-end spending, bureaus should request budget adjustments
to avoid over-expenditure by major object categories.

Other Adjustments
As in the Fall BMP, budget requests can be made to reflect contingency funding approved by Council,
additional contingency requests, or other budget changes.

Spring Supplemental Budgeting – Entry into BRASS
Instructions for entering budget adjustments into BRASS during the Spring BMP follow the same format
as provided in the Fall BMP section of this manual on pages 18-24.
As discussed in the general guidelines above, Program Carryover and Compensation Set Aside requests
are types of budget adjustments that are unique to the Spring BMP. Please be sure to select the
appropriate “Type” category (“Program Carryover Request”, Compensation Set Aside
Request, etc) when setting up your requested decision package in the info edit window. Program
Carryover requests take the form of budget reductions, which enables the funds to be re-appropriated
in the subsequent years’ Adopted Budget.
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Over-Expenditure Ordinance
Instructions
The Over-Expenditure Ordinance occurs during the month of June and is timed to be approved during
the last or penultimate City Council meeting of the fiscal year. The ordinance is narrowly focused on
addressing fund-, bureau- and major object-level over-expenditures and interfund loans to ensure that
funds do not end the fiscal year with negative cash or fund balances. No other budget adjustments
should be requested.
‘Over-expenditure’ is defined legally as spending in excess of amounts that are legally appropriated. The
City appropriates at the fund, bureau, and ‘appropriation category.’ Appropriation categories are bureau
program expenses (personnel services, external materials and services, internal materials and services,
and capital), debt service, interfund cash transfers, and contingency. In addition to this legal definition,
CBO monitors budgets at the major object level, noting and reporting where discrepancies between
budget and actual spending and receipt of revenues occur. This is a high-level roll-up that is established
in the SAP and BRASS hierarchies.
Formal submission of budget monitoring reports is not necessary during the OEO process. However,
bureaus may be asked to share projections for the final month of the year to compare with CBO
projections. These projections should be based on AP 11 actuals and be quite precise predictors of how
bureaus will finish the fiscal year.

Interfund Loans
As noted above, interfund loans are occasionally necessary to ensure that funds do not end the year
with a negative cash or fund balance. During the OEO, CBO budget analysts work with technical
accounting, the OMF Grants Unit, and bureau staff to determine if loans are necessary. These loans will
be budgeted in the OEO and authorized through a separate, companion resolution.
Typically, the amounts budgeted will be conservative and encompass the largest anticipated loan
required. When the year closes and the final amount is determined, the loan is made and posted on
June 30 of the prior year; the repayment is ideally posted on July 1 of the following year, requiring the
Fall BMP adjustment noted above.
Budgeting
In early June, the Grants Office runs a cash report for accounting periods 1-11 by fund and business area
using tcode FAGLL03, account 100000, funds 217000-217015, 218000-218002 and 219000-219001.
After the cash report is complete, expense projections for June are calculated and incorporated into the
cash report. The projections are based on average monthly expense incurred by each grant in AP 1-11.
Each grant is attributable to a specific bureau. The cash report is submitted to CBO and Technical
Accounting prior to the BRASS deadline for the Over Expenditure Ordinance (OEO).
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CBO works with the bureau budget analyst to complete the BRASS load for the year-end loans. CBO and
the bureau budget analysts will communicate the Grants Fund loan information to bureau accounting
staff.
Loans will be budgeted in the OEO and, simultaneously, the repayments will be budgeted in the Adopted
Budget for the next fiscal year (to the degree that the appropriation doesn’t increase the Approved
Budget appropriation for the fund by more than 10%). This ensures that authority exists both to make
the loan on June 30th, and to repay it the next day, July 1. CBO will work with bureau budget analysts to
make sure that the loans are correctly budgeted.
The loans must be authorized in a separate resolution by Council. The resolution must contain the
purpose, amount, and terms of the loan. Language in the resolution standardly specifies that the loans
will not accrue interest. (Because of the negative cash generated by the bureau, the City pooled cash
overall receives less interest. It would be inappropriate to pay bureaus interest on amounts due to the
Grants Fund due to a negative cash balance.) CBO will prepare the Grants Fund loan resolution to
address these criteria.
Accounting: Year-End Grants Fund Loan Journal Entry
In October, the Grants Office and Technical Accounting will prepare the final cash and fund balance
reports based on actual results of the full fiscal year. The cash and fund balance report will be provided
to CBO. CBO will work with Bureau Budget Analyst and Accounting Staff to determine the bureau’s
funding source for their portion of the loans to the Grants Fund. CBO will notify the Grants Office and
Technical Accounting of the loan funding source determination.
Technical Accounting will complete a JE recording the loans and a JE recording the loan repayment. The
loan JE is always dated June 30 in accounting period 13, and the repayment JE is always dated July 1 of
the subsequent fiscal year in accounting period one. These two entries will be entered in SAP at the
same time to avoid any interest allocation issues and to avoid the possibility of failing to reverse the loan
JE. Technical Accounting park the documents in SAP, and then notify the bureaus and the Grants Office
of the document number requiring their review and a note of approval to be placed in the SAP
document attachment After the Bureaus review and place an attachment stating approval of the
entries, they will notify Technical Accounting that the entries are ready for completion/approval and
posting.
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Submittal
Submittal Item Summary
As discussed in The BMP Cycle each BMP has different submittal requirements. Below is a summary of
what constitutes a complete submission for each BMP:

Item
Letter from Director
Budget Amendment Request Report
(BRASS F4)
Prior Year Budget/Actuals
Reconciliations (BRASS A1 and A1a)

Fall BMP

Spring BMP

x

x

x

x

x

x

Prior Year Budget Note Update

x

Prior Year Decision Package Update
(including non-technical BMP requests)

x

Prior Year Performance Measure Update

x

Prior Year Capital Reporting (BRASS C2)

x

Current Year Projections (BRASS A2 and
A3)

x

Current Year Budget Note Update

x

Current Year Decision Package Update
(including non-technical BMP requests)
Current Year Capital Reporting (BRASS
C2)
Encumbrance Carryover Detail
Spreadsheet

OEO

x
x

x

x
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Fall and Spring BMP submittals must include a cover letter from the bureau director to CBO that
summarizes any requests for significant budget amendments or new budget allocations. All bureaus are
responsible for briefing their Commissioner-in-Charge regarding their financial and program
performance and budget amendment requests. All other submittal requirements have been discussed in
earlier sections.

Distribution
Submit an electronic set of all required items to the CBO analyst assigned to the bureau on or before the
due date. Hard copy submittals are no longer required. Distribution to elected officials is no longer
necessary. CBO will compile submittals, post them, and distribute the link.
Electronic submittals should be pdfs or Microsoft Word (for decision package and budget note updates)
or Excel files.

Technical Checks
Prior to submittal, bureaus should perform checks to ensure that submissions are technically sufficient.
These technical checks are described in detail below. A checklist is provided in Appendix A: Technical
Checklist.
The following checks use the BMP Submittal spreadsheet views in BRASS. In the BMP database, select
BRASS>Spreadsheet Views, check the Show Public box, select from the View Name drop-down menu the
BMP Submittal view associated with the current BMP, select the desired two-character fund center from
the Funds Ctr drop-down menu, press the Fund radio button in the Sections section, select ‘3- Fund’
from the Level drop-down menu, and click Okay. For all these checks, lines with amounts of 0 are
equivalent to there being ‘no lines.’
1. Every adjustment has a request number. On the City tab, zoom into the expense of the total changes
column. Sort by Request #. No lines should have a ‘0’ in this column. Repeat for Revenue.
2. General Fund discretionary requests use the one-time (487120) account. On the City tab, zoom into
General Fund Discretionary in the total changes column, expanded by detailed objects. Sort by
CommItem. There should be no instances of the ongoing account (487110) except in the case of internal
shifts of ongoing resources that net to zero. New ongoing funds are not allocated outside of the annual
budget development process.
3. No requests use the General Fund discretionary offset account (487100). Use the same view as the
previous check. This account is for CBO use only. It is an offset account used to translate other sources
of revenue (property taxes, business license fees, etc.) into discretionary resources.
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4. No requests use the General Fund Overhead account (487210). On the City tab, zoom into General
Fund Overhead total of total changes column, expanded by detailed objects. Sort by CommItem.
Overhead requests are not allowed mid-year except to shift the resource internally through net zero
changes.
5. No requests use the General Fund Overhead offset account (487200). Use the same view as the
previous check. Similar to the General Fund discretionary offset account, this account is for CBO use
only. It is used to translate cash transfer revenues from overhead paying bureaus into overhead
resources for General Fund bureaus.
6. Revenues and expenses balance by fund. Click through all the fund tabs of the spreadsheet view to
check that the total changes and the revised budget column are balanced for each fund.
7. No requests reduce ending fund balance accounts (500001-500002). On the City tab, zoom into the
Unappropriated Fund Balance in the total changes column, expanded by detailed objects. Sort by
CommItem. There should be no instances of these accounts being reduced. Local budget law requires
that City Council declare that an emergency exists in order to draw down ending fund balance.
8. All internal materials and services interagency revenue entries have the correct funded program. On
the City tab, zoom into each of these major objects in the total changes column, expanded by detailed
objects. Sort by CommItem. All expense accounts beginning with 651XXX or revenue accounts beginning
with 641XXX should have either a capital project funded program or a funded program beginning with
‘3’. All expense accounts beginning with 652XXX or revenue accounts beginning with 642XXX should
have either a capital project funded program or a funded program beginning with ‘7’.
9. All fund transfer expense and revenue entries have the correct funded program. On the City tab, zoom
into each of these major objects in the total changes column, expanded by detailed objects. Sort by
CommItem. All lines should have a funded program beginning with ‘1’. Capital funded programs are not
allowed for cash transfers.
10. All entries with a bureau-to-bureau, internal service, or cash transfer funded program have an
appropriate commitment item. On the City tab, zoom into the expense and revenue totals in the total
changes column, expanded by detailed objects. Sort by Fnd Program. Every funded program beginning
with ‘1’ should have a 650020 or 640020 account. Every funded program beginning with ‘3’ should have
an account beginning with 651XXX or 641XXX. Every funded program beginning with ‘7’ should have an
account beginning with 652XXX or 642XXX. (Note: The fourth digit in the internal service provider
accounts indicates the providing bureau. Make sure an appropriate account is used for the selected
funded program, i..e. 6511XX for CityFleet, 6512XX for P&D, 6513XX for Facilities, 6514XX for EBS,
6515XX for Technology Services, and 6516XX for Risk Management.)
11. No cash transfers from the General Fund. Use the same view and sort as the check above for expense
totals only. Sort by funded program. There should not be any funded programs that begin ‘1GENF2’ in
the General Fund. All transfers from the General Fund originate from an OMF fund center managed by
CBO. If a bureau wishes to request a transfer from the General Fund (either from within their bureau or
from another bureau) to a fund that it manage, then it should only show the receiving side of the
transfer. A commensurate reduction in expenses funded by General Fund discretionary should be
entered by the sending bureau. The CBO General Fund analyst will identify the imbalance in the cash
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transfer funded program and enter the sending side from the General Fund fund management cost
center.
12. All interagencies and cash transfers balance at the funded program and account level. Select
BRASS>Reports>IA1, click Okay, then click Okay again. Check all variances Citywide to see if there are
any imbalances between your bureau and any other bureau, either on the sending or receiving side of a
service. Repeat this process for the IA2 and IA3 reports. If bureau staff believes that the entry for their
bureau’s side of an IA or cash transfer is not correct, it is still that bureau’s responsibility to work with
the other party to correct the variance prior to submittal. If consensus is not possible prior to submittal,
the variance must be noted in the memo from the bureau director to indicate that it requires a City
Council decision. Exception: Adjustments to cash transfers from the General Fund will almost always be
unbalanced upon submittal as they require balancing by the CBO General Fund analyst.
13. All grant entries have grant codes. On the 217 fund tab, zoom into the expense and revenue totals in
the total changes column, expanded by detailed objects. Sort by Grant. There should be no lines with a
‘0’ in the Grant column. The Portland Housing Bureau should repeat this check for funds 218 and 219.
14. No funds other than grants funds have entries with grant codes. On the City tab, zoom into the
expense and revenue totals in the total changes column, expanded by detailed objects. Sort by Grant.
The only entries with grant codes should be in 217, 218, and 219 funds.
15. All entries using the Grant Revenue account (441100) should have a grant code and grant fund
associated with them. Use the same view as the check above. Sort by CommItem and scroll down to the
441100 item. All entries should a) have a grant code and b) be in fund 217, 218, or 219.
The following checks do not utilize the spreadsheet view described above. Please follow the instructions
for each check.
1. No entries use cents. Open the bureau’s budget form. Click on the top cell in the Adjustments column.
Use the arrow down key to scroll through all the lines of the form. As each cell is highlighted, the
inclusion of cents – if there are any – will become apparent. Cents cause rounding and balancing
problems when the BMP is loaded to SAP. If more than one form is used, repeat for all forms used
during this BMP.
2. All grant entries include the sponsored program as the first information in the Justify column. In the
budget form, sort by Fund. Check the Justify column for each entry in the 217, 218, and 219 funds to
ensure that they begin with sponsored program information.
3. All grants balance revenues and expenses. BRASS>Advanced Spreadsheet Views, check Show Public
box, select Grants_Balancing from the View Name drop-down menu, and click Okay. Scroll through the
output to check that the Difference column is zero for all grants with your bureau’s prefix. Any non-zero
number indicates that the grant is out of balance.
4. All bureau allocation accounts net to zero. BRASS>Advanced Spreadsheet Views, check the Show Public
box, select Allocation_CI_Balancer from the View Name drop-down menu, and click Okay. Scroll through
the output to check that the Revised Budget column is zero for all accounts in your bureau. Any nonzero number indicates that expenses are over- or under-allocated.
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5. No fund-business area-commitment item structures are negative. BRASS>Advanced Spreadsheet
Views, check the Show Public box, select Negative_Structures from the View Name drop-down menu,
and click Okay. Scroll through the output to check that the Revised Budget column is not negative for all
accounts in your bureau. There are some exceptions to this check. The most typical is 487120 which can
be negative to reflect a one-time cut to an ongoing program. Other exceptions exist. Bureaus should
discuss possible exceptions with their CBO analyst.
Upon submission, CBO will perform the checks noted above as well as a number of additional checks.
The additional checks are primarily to ensure that the content of titles and narratives is complete and
accurate.
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Appendix A: Technical Checklist
Every adjustment has a request number.
General Fund discretionary requests use the one-time (487120) account.
No requests use the General Fund discretionary offset account (487100).
No requests use the General Fund Overhead account (487210).
No requests use the General Fund Overhead offset account (487200).
Revenues and expenses balance by fund.
No requests reduce ending fund balance accounts (500001-500002).
All internal materials and services interagency revenue entries have the correct funded
program.
All fund transfer expense and revenue entries have the correct funded program.
All entries with a bureau-to-bureau, internal service, or cash transfer funded program have an
appropriate commitment item.
No cash transfers from the General Fund.
All interagencies and cash transfers balance at the funded program and account level.
All grant entries have grant codes.
No funds other than grants funds have entries with grant codes.
All entries using the Grant Revenue account (441100) should have a grant code and grant fund
associated with them.
No entries use cents.
All grant entries include the sponsored program as the first information in the Justify column.
All grants balance revenues and expenses.
All bureau allocation accounts net to zero.
No fund-business area-commitment item structures are negative. (Some exceptions exist.)
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